aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-mediatek/patches/412-add-ubnt-unifi-6-lr.patch
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2022-07-11 11:02:49 +0100
committerDaniel Golle <daniel@makrotopia.org>2022-07-11 17:13:22 +0100
commitfa75a3a935b26378630498ba7d3f6a0b5b11f86e (patch)
tree33e32eb3c87e7fa7e5dea1fc3bf7799a0738a9b3 /package/boot/uboot-mediatek/patches/412-add-ubnt-unifi-6-lr.patch
parentb68e9f2e19a4cc7be4dd13b76a690ef04daac190 (diff)
downloadupstream-fa75a3a935b26378630498ba7d3f6a0b5b11f86e.tar.gz
upstream-fa75a3a935b26378630498ba7d3f6a0b5b11f86e.tar.bz2
upstream-fa75a3a935b26378630498ba7d3f6a0b5b11f86e.zip
uboot-mediatek: update to 2022.07 release
Add patch to fix host-build of the mkimage tool without CONFIG_TOOLS_LIBCRYPTO. Update and refresh all patches. Tested on BananaPi R64 (MT7622) successfully booting from SD card, eMMC and SPI-NAND. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'package/boot/uboot-mediatek/patches/412-add-ubnt-unifi-6-lr.patch')
-rw-r--r--package/boot/uboot-mediatek/patches/412-add-ubnt-unifi-6-lr.patch12
1 files changed, 6 insertions, 6 deletions
diff --git a/package/boot/uboot-mediatek/patches/412-add-ubnt-unifi-6-lr.patch b/package/boot/uboot-mediatek/patches/412-add-ubnt-unifi-6-lr.patch
index 09a727422a..bb7045916f 100644
--- a/package/boot/uboot-mediatek/patches/412-add-ubnt-unifi-6-lr.patch
+++ b/package/boot/uboot-mediatek/patches/412-add-ubnt-unifi-6-lr.patch
@@ -349,7 +349,7 @@
+};
--- a/arch/arm/dts/Makefile
+++ b/arch/arm/dts/Makefile
-@@ -1134,6 +1134,7 @@ dtb-$(CONFIG_ARCH_MEDIATEK) += \
+@@ -1204,6 +1204,7 @@ dtb-$(CONFIG_ARCH_MEDIATEK) += \
mt7623a-unielec-u7623-02-emmc.dtb \
mt7622-bananapi-bpi-r64.dtb \
mt7622-linksys-e8450-ubi.dtb \
@@ -412,15 +412,15 @@
+_bootmenu_update_title=setenv _bootmenu_update_title ; setenv bootmenu_title "$bootmenu_title $ver"
--- a/common/board_r.c
+++ b/common/board_r.c
-@@ -78,6 +78,7 @@
- #ifdef CONFIG_EFI_SETUP_EARLY
+@@ -62,6 +62,7 @@
+ #include <asm-generic/gpio.h>
#include <efi_loader.h>
- #endif
+ #include <relocate.h>
+#include <spi_flash.h>
DECLARE_GLOBAL_DATA_PTR;
-@@ -417,6 +418,21 @@ static int initr_onenand(void)
+@@ -392,6 +393,21 @@ static int initr_onenand(void)
}
#endif
@@ -442,7 +442,7 @@
#ifdef CONFIG_MMC
static int initr_mmc(void)
{
-@@ -705,6 +721,9 @@ static init_fnc_t init_sequence_r[] = {
+@@ -703,6 +719,9 @@ static init_fnc_t init_sequence_r[] = {
#ifdef CONFIG_CMD_ONENAND
initr_onenand,
#endif