aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-mediatek/patches/000-mtk-14-drivers-mtd-add-support-for-MediaTek-SPI-NAND-flash-.patch
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2022-01-11 21:26:43 +0000
committerDaniel Golle <daniel@makrotopia.org>2022-01-23 20:20:53 +0000
commit145d896e0e68cef80880700060169cc004a7b46e (patch)
tree37176474dadac512fa76a60860d4ef0ffa164328 /package/boot/uboot-mediatek/patches/000-mtk-14-drivers-mtd-add-support-for-MediaTek-SPI-NAND-flash-.patch
parentf5278bf820105c83267d6bc0ad3dfaf1d77a4681 (diff)
downloadupstream-145d896e0e68cef80880700060169cc004a7b46e.tar.gz
upstream-145d896e0e68cef80880700060169cc004a7b46e.tar.bz2
upstream-145d896e0e68cef80880700060169cc004a7b46e.zip
uboot-mediatek: update to version 2022.01
Tested on BananaPi R2 (SD, eMMC), BananaPi R64 (SD, eMMC, SPI-NAND) and UniElec U7623-02 (eMMC). Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'package/boot/uboot-mediatek/patches/000-mtk-14-drivers-mtd-add-support-for-MediaTek-SPI-NAND-flash-.patch')
-rw-r--r--package/boot/uboot-mediatek/patches/000-mtk-14-drivers-mtd-add-support-for-MediaTek-SPI-NAND-flash-.patch14
1 files changed, 6 insertions, 8 deletions
diff --git a/package/boot/uboot-mediatek/patches/000-mtk-14-drivers-mtd-add-support-for-MediaTek-SPI-NAND-flash-.patch b/package/boot/uboot-mediatek/patches/000-mtk-14-drivers-mtd-add-support-for-MediaTek-SPI-NAND-flash-.patch
index d743035813..dead0db174 100644
--- a/package/boot/uboot-mediatek/patches/000-mtk-14-drivers-mtd-add-support-for-MediaTek-SPI-NAND-flash-.patch
+++ b/package/boot/uboot-mediatek/patches/000-mtk-14-drivers-mtd-add-support-for-MediaTek-SPI-NAND-flash-.patch
@@ -38,15 +38,15 @@ Signed-off-by: Weijie Gao <weijie.gao@mediatek.com>
--- a/drivers/mtd/Kconfig
+++ b/drivers/mtd/Kconfig
-@@ -109,6 +109,8 @@ config HBMC_AM654
- This is the driver for HyperBus controller on TI's AM65x and
- other SoCs
+@@ -116,6 +116,8 @@ config STM32_FLASH
+ This is the driver of embedded flash for some STMicroelectronics
+ STM32 MCU.
+source "drivers/mtd/mtk-snand/Kconfig"
+
source "drivers/mtd/nand/Kconfig"
- source "drivers/mtd/spi/Kconfig"
+ config SYS_NAND_MAX_CHIPS
--- a/drivers/mtd/Makefile
+++ b/drivers/mtd/Makefile
@@ -39,3 +39,5 @@ obj-$(CONFIG_$(SPL_TPL_)SPI_FLASH_SUPPOR
@@ -1145,7 +1145,7 @@ Signed-off-by: Weijie Gao <weijie.gao@mediatek.com>
+}
--- /dev/null
+++ b/drivers/mtd/mtk-snand/mtk-snand-mtd.c
-@@ -0,0 +1,526 @@
+@@ -0,0 +1,524 @@
+// SPDX-License-Identifier: GPL-2.0
+/*
+ * Copyright (C) 2020 MediaTek Inc. All Rights Reserved.
@@ -1225,9 +1225,7 @@ Signed-off-by: Weijie Gao <weijie.gao@mediatek.com>
+ else
+ instr->state = MTD_ERASE_DONE;
+
-+ if (!ret)
-+ mtd_erase_callback(instr);
-+ else
++ if (ret)
+ ret = -EIO;
+
+ return ret;