aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-mediatek/Makefile
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2022-07-12 03:41:30 +0100
committerDaniel Golle <daniel@makrotopia.org>2022-08-28 20:33:15 +0100
commitc09eb08dadae341e7f68d34e9ec3f15afd86e469 (patch)
tree742836f04e6b1e49f297cfdc7ad3ba627b6cb156 /package/boot/uboot-mediatek/Makefile
parenta4933cdd121d1689764445441f6e7fcf67dd3beb (diff)
downloadupstream-c09eb08dadae341e7f68d34e9ec3f15afd86e469.tar.gz
upstream-c09eb08dadae341e7f68d34e9ec3f15afd86e469.tar.bz2
upstream-c09eb08dadae341e7f68d34e9ec3f15afd86e469.zip
uboot-mediatek: add support for MT798x platforms
Import pending patches to support the upcoming Filogic platforms. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'package/boot/uboot-mediatek/Makefile')
-rw-r--r--package/boot/uboot-mediatek/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/package/boot/uboot-mediatek/Makefile b/package/boot/uboot-mediatek/Makefile
index a8add7ef94..c89fb197ae 100644
--- a/package/boot/uboot-mediatek/Makefile
+++ b/package/boot/uboot-mediatek/Makefile
@@ -175,6 +175,14 @@ define U-Boot/mt7629_rfb
UBOOT_CONFIG:=mt7629_rfb
endef
+define U-Boot/mt7986_rfb
+ NAME:=MT7986 Reference Board
+ BUILD_SUBTARGET:=filogic
+ BUILD_DEVICES:=mediatek_mt7986-rfb
+ UBOOT_CONFIG:=mt7986_rfb
+ UBOOT_IMAGE:=u-boot.bin
+endef
+
UBOOT_TARGETS := \
mt7620_mt7530_rfb \
mt7620_rfb \
@@ -190,7 +198,8 @@ UBOOT_TARGETS := \
mt7623a_unielec_u7623 \
mt7628_rfb \
ravpower_rp-wd009 \
- mt7629_rfb
+ mt7629_rfb \
+ mt7986_rfb
ifdef CONFIG_TARGET_mediatek
UBOOT_MAKE_FLAGS += $(UBOOT_IMAGE:.fip=.bin)