aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-mediatek/Makefile
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2021-08-19 03:57:00 +0100
committerDaniel Golle <daniel@makrotopia.org>2021-10-04 20:46:30 +0100
commitb6da10f2d1b82ca3c6d7cac55403d93b64828cdd (patch)
tree832f5db95a82e9b9355a328f89f822af5ef48bb4 /package/boot/uboot-mediatek/Makefile
parented7769aa405fe246b89c9c97b7fb552dfb0b4995 (diff)
downloadupstream-b6da10f2d1b82ca3c6d7cac55403d93b64828cdd.tar.gz
upstream-b6da10f2d1b82ca3c6d7cac55403d93b64828cdd.tar.bz2
upstream-b6da10f2d1b82ca3c6d7cac55403d93b64828cdd.zip
uboot-mediatek: update to 2021.10
U-Boot 2021.10 has been released. Rebase mediatek patches on top of new release and remove some patches which have been merged upstream. Tested on Bananapi BPi-R2 (mt7623), Bananapi BPi-R64 (mt7622) and Linksys E8450 (mt7622). Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'package/boot/uboot-mediatek/Makefile')
-rw-r--r--package/boot/uboot-mediatek/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/package/boot/uboot-mediatek/Makefile b/package/boot/uboot-mediatek/Makefile
index 37af42e664..a5801afa2d 100644
--- a/package/boot/uboot-mediatek/Makefile
+++ b/package/boot/uboot-mediatek/Makefile
@@ -1,8 +1,8 @@
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
-PKG_VERSION:=2021.04
-PKG_HASH:=0d438b1bb5cceb57a18ea2de4a0d51f7be5b05b98717df05938636e0aadfe11a
+PKG_VERSION:=2021.10
+PKG_HASH:=cde723e19262e646f2670d25e5ec4b1b368490de950d4e26275a988c36df0bd4
PKG_BUILD_DEPENDS:=arm-trusted-firmware-tools/host
include $(INCLUDE_DIR)/u-boot.mk
@@ -120,6 +120,11 @@ define Build/fip-image
$(PKG_BUILD_DIR)/u-boot.fip
endef
+define Build/Configure
+ $(call Build/Configure/U-Boot)
+ sed -i 's/CONFIG_TOOLS_LIBCRYPTO=y/# CONFIG_TOOLS_LIBCRYPTO is not set/' $(PKG_BUILD_DIR)/.config
+endef
+
define Build/Compile
$(call Build/Compile/U-Boot)
ifeq ($(UBOOT_IMAGE),u-boot.fip))