aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-mediatek/Makefile
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2022-12-02 04:29:58 +0000
committerDaniel Golle <daniel@makrotopia.org>2023-04-22 04:10:19 +0100
commitcc00e220291c9d894fef42d19ee9c59136962123 (patch)
tree965f5083adea453c8b30bbae54dd5f8c8d0835b4 /package/boot/uboot-mediatek/Makefile
parent998b9731577dedc7747dcfa412e4543dabaaa131 (diff)
downloadupstream-cc00e220291c9d894fef42d19ee9c59136962123.tar.gz
upstream-cc00e220291c9d894fef42d19ee9c59136962123.tar.bz2
upstream-cc00e220291c9d894fef42d19ee9c59136962123.zip
uboot-mediatek: add TP-Link TL-XDR4288 and TL-XDR608x
TP-Link TL-XDR608x comes with locked vendor loader. Add U-Boot build for replacement loader for both TL-XDR6086 and TL-XDR6088. The only difference at U-Boot level is the different filename requested via TFTP, matching the corresponding OpenWrt build artifacts for each device. The TP-Link TL-XDR4288 has the same hardware as the TP-Link TL-XDR6088 except for the wireless part. Also create a uboot for the TP-Link TL-XDR4288. Signed-off-by: Daniel Golle <daniel@makrotopia.org> [rebase to uboot 23.04, correct led and button] Signed-off-by: Chukun Pan <amadeus@jmu.edu.cn>
Diffstat (limited to 'package/boot/uboot-mediatek/Makefile')
-rw-r--r--package/boot/uboot-mediatek/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/package/boot/uboot-mediatek/Makefile b/package/boot/uboot-mediatek/Makefile
index 938ed227bd..12c305617b 100644
--- a/package/boot/uboot-mediatek/Makefile
+++ b/package/boot/uboot-mediatek/Makefile
@@ -237,6 +237,42 @@ define U-Boot/mt7986_bananapi_bpi-r3-nor
FIP_COMPRESS:=1
endef
+define U-Boot/mt7986_tplink_tl-xdr4288
+ NAME:=TP-LINK TL-XDR4288
+ BUILD_SUBTARGET:=filogic
+ BUILD_DEVICES:=tplink_tl-xdr4288
+ UBOOT_CONFIG:=mt7986_tplink_tl-xdr4288
+ UBOOT_IMAGE:=u-boot.fip
+ BL2_BOOTDEV:=spim-nand
+ BL2_SOC:=mt7986
+ BL2_DDRTYPE:=ddr3
+ DEPENDS:=+trusted-firmware-a-mt7986-spim-nand-ddr3
+endef
+
+define U-Boot/mt7986_tplink_tl-xdr6086
+ NAME:=TP-LINK TL-XDR6086
+ BUILD_SUBTARGET:=filogic
+ BUILD_DEVICES:=tplink_tl-xdr6086
+ UBOOT_CONFIG:=mt7986_tplink_tl-xdr6086
+ UBOOT_IMAGE:=u-boot.fip
+ BL2_BOOTDEV:=spim-nand
+ BL2_SOC:=mt7986
+ BL2_DDRTYPE:=ddr3
+ DEPENDS:=+trusted-firmware-a-mt7986-spim-nand-ddr3
+endef
+
+define U-Boot/mt7986_tplink_tl-xdr6088
+ NAME:=TP-LINK TL-XDR6088
+ BUILD_SUBTARGET:=filogic
+ BUILD_DEVICES:=tplink_tl-xdr6088
+ UBOOT_CONFIG:=mt7986_tplink_tl-xdr6088
+ UBOOT_IMAGE:=u-boot.fip
+ BL2_BOOTDEV:=spim-nand
+ BL2_SOC:=mt7986
+ BL2_DDRTYPE:=ddr3
+ DEPENDS:=+trusted-firmware-a-mt7986-spim-nand-ddr3
+endef
+
define U-Boot/mt7986_xiaomi_redmi-router-ax6000
NAME:=Xiaomi Redmi AX6000
BUILD_SUBTARGET:=filogic
@@ -269,6 +305,9 @@ UBOOT_TARGETS := \
mt7986_bananapi_bpi-r3-sdmmc \
mt7986_bananapi_bpi-r3-snand \
mt7986_bananapi_bpi-r3-nor \
+ mt7986_tplink_tl-xdr4288 \
+ mt7986_tplink_tl-xdr6086 \
+ mt7986_tplink_tl-xdr6088 \
mt7986_xiaomi_redmi-router-ax6000 \
mt7986_rfb