aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-mediatek/Makefile
diff options
context:
space:
mode:
authorChukun Pan <amadeus@jmu.edu.cn>2023-04-28 23:36:17 +0800
committerDaniel Golle <daniel@makrotopia.org>2023-05-29 13:04:14 +0100
commit99c94c669618c37ab4e6c888e46f59fb7197f86a (patch)
tree943d000db6ebec71e4fafde65952eaeddec49c5e /package/boot/uboot-mediatek/Makefile
parentf588da89a3341c4c876255944daac087d8050c24 (diff)
downloadupstream-99c94c669618c37ab4e6c888e46f59fb7197f86a.tar.gz
upstream-99c94c669618c37ab4e6c888e46f59fb7197f86a.tar.bz2
upstream-99c94c669618c37ab4e6c888e46f59fb7197f86a.zip
uboot-mediatek: add Qihoo 360T7 support
The vendor uboot will verify firmware at boot. So add a custom uboot build for this device. Signed-off-by: Chukun Pan <amadeus@jmu.edu.cn> (cherry picked from commit c51eb177308835f811ae43b17dde0ea962ed1df1) Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'package/boot/uboot-mediatek/Makefile')
-rw-r--r--package/boot/uboot-mediatek/Makefile13
1 files changed, 13 insertions, 0 deletions
diff --git a/package/boot/uboot-mediatek/Makefile b/package/boot/uboot-mediatek/Makefile
index 12c305617b..8ea05b9159 100644
--- a/package/boot/uboot-mediatek/Makefile
+++ b/package/boot/uboot-mediatek/Makefile
@@ -176,6 +176,18 @@ define U-Boot/mt7629_rfb
UBOOT_CONFIG:=mt7629_rfb
endef
+define U-Boot/mt7981_qihoo_360t7
+ NAME:=Qihoo 360T7
+ BUILD_SUBTARGET:=filogic
+ BUILD_DEVICES:=qihoo_360t7
+ UBOOT_CONFIG:=mt7981_qihoo-360t7
+ UBOOT_IMAGE:=u-boot.fip
+ BL2_BOOTDEV:=spim-nand
+ BL2_SOC:=mt7981
+ BL2_DDRTYPE:=ddr3
+ DEPENDS:=+trusted-firmware-a-mt7981-spim-nand-ddr3
+endef
+
define U-Boot/mt7986_rfb
NAME:=MT7986 Reference Board
BUILD_SUBTARGET:=filogic
@@ -301,6 +313,7 @@ UBOOT_TARGETS := \
mt7628_rfb \
ravpower_rp-wd009 \
mt7629_rfb \
+ mt7981_qihoo_360t7 \
mt7986_bananapi_bpi-r3-emmc \
mt7986_bananapi_bpi-r3-sdmmc \
mt7986_bananapi_bpi-r3-snand \