aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-mediatek/Makefile
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2021-02-27 15:14:02 +0000
committerDaniel Golle <daniel@makrotopia.org>2021-02-28 03:40:35 +0000
commit03948995abd0c03e8fb6628e2368b6c9f5785eae (patch)
tree30f0773be9bf2fc64389bc27b994a1a3d8abe661 /package/boot/uboot-mediatek/Makefile
parent049ac36b2fdd9866e317282ea517851c0c190206 (diff)
downloadupstream-03948995abd0c03e8fb6628e2368b6c9f5785eae.tar.gz
upstream-03948995abd0c03e8fb6628e2368b6c9f5785eae.tar.bz2
upstream-03948995abd0c03e8fb6628e2368b6c9f5785eae.zip
uboot-mediatek: rework support for Bananapi BPi-R64 board
Provide U-Boot variants for SD-card as well as eMMC boot, so we can generate whole-disk images for the device. While at it, rename 'mt7622' to 'mt7622-rfb1' to make it less confusing now that more boards are being added. Thanks to Frank Wunderlich (@frank-w) for making that nice SVG image explaining the MMC boot process[1] and for providing the necessary binary header blobs. [1]: https://github.com/frank-w/BPI-R64-ATF Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'package/boot/uboot-mediatek/Makefile')
-rw-r--r--package/boot/uboot-mediatek/Makefile33
1 files changed, 30 insertions, 3 deletions
diff --git a/package/boot/uboot-mediatek/Makefile b/package/boot/uboot-mediatek/Makefile
index b61f432644..6904b39938 100644
--- a/package/boot/uboot-mediatek/Makefile
+++ b/package/boot/uboot-mediatek/Makefile
@@ -15,8 +15,8 @@ define U-Boot/Default
DEFAULT:=y
endef
-define U-Boot/mt7622
- NAME:=MT7622
+define U-Boot/mt7622_rfb1
+ NAME:=MT7622 Reference Board 1
BUILD_SUBTARGET:=mt7622
UBOOT_CONFIG:=mt7622_rfb
endef
@@ -31,6 +31,26 @@ define U-Boot/mt7622_linksys_e8450
DEPENDS:=+trusted-firmware-a-mt7622-snand-1ddr
endef
+define U-Boot/mt7622_bananapi_bpi-r64-emmc
+ NAME:=BananaPi R64 (eMMC)
+ BUILD_SUBTARGET:=mt7622
+ UBOOT_CONFIG:=mt7622_bananapi_bpi-r64-emmc
+ UBOOT_IMAGE:=u-boot.fip
+ BL2_BOOTDEV:=emmc
+ BL2_DDRBLOB:=2
+ DEPENDS:=+trusted-firmware-a-mt7622-emmc-2ddr
+endef
+
+define U-Boot/mt7622_bananapi_bpi-r64-sdmmc
+ NAME:=BananaPi R64 (SDMMC)
+ BUILD_SUBTARGET:=mt7622
+ UBOOT_CONFIG:=mt7622_bananapi_bpi-r64-sdmmc
+ UBOOT_IMAGE:=u-boot.fip
+ BL2_BOOTDEV:=sdmmc
+ BL2_DDRBLOB:=2
+ DEPENDS:=+trusted-firmware-a-mt7622-sdmmc-2ddr
+endef
+
define U-Boot/mt7623a_unielec_u7623
NAME:=UniElec U7623 (mt7623)
BUILD_SUBTARGET:=mt7623
@@ -50,7 +70,14 @@ define U-Boot/mt7629
UBOOT_CONFIG:=mt7629_rfb
endef
-UBOOT_TARGETS := mt7629 mt7622 mt7622_linksys_e8450 mt7623n_bpir2 mt7623a_unielec_u7623
+UBOOT_TARGETS := \
+ mt7629 \
+ mt7622_bananapi_bpi-r64-emmc \
+ mt7622_bananapi_bpi-r64-sdmmc \
+ mt7622_linksys_e8450 \
+ mt7622_rfb1 \
+ mt7623n_bpir2 \
+ mt7623a_unielec_u7623
UBOOT_MAKE_FLAGS += $(UBOOT_IMAGE:.fip=.bin)