aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-mediatek/Makefile
diff options
context:
space:
mode:
authorDavid Woodhouse <dwmw2@infradead.org>2020-07-13 10:37:28 +0100
committerChuanhong Guo <gch981213@gmail.com>2020-07-26 16:42:36 +0800
commitad295e0ee81b61b667f6e38418b02006aea7c5aa (patch)
treeb22394a43c17f2ceba3f54484dbc544115bde556 /package/boot/uboot-mediatek/Makefile
parentff8cc137fb999d2f828cfaa53584fa77138836ed (diff)
downloadupstream-ad295e0ee81b61b667f6e38418b02006aea7c5aa.tar.gz
upstream-ad295e0ee81b61b667f6e38418b02006aea7c5aa.tar.bz2
upstream-ad295e0ee81b61b667f6e38418b02006aea7c5aa.zip
mediatek: add U-Boot build for UniElec U7623
Patches submitted upstream at https://patchwork.ozlabs.org/project/uboot/list/?series=189178 Tested on Banana Pi R2 and U7623-06. Signed-off-by: David Woodhouse <dwmw2@infradead.org>
Diffstat (limited to 'package/boot/uboot-mediatek/Makefile')
-rw-r--r--package/boot/uboot-mediatek/Makefile20
1 files changed, 13 insertions, 7 deletions
diff --git a/package/boot/uboot-mediatek/Makefile b/package/boot/uboot-mediatek/Makefile
index a7b47ecae5..8cb20075a3 100644
--- a/package/boot/uboot-mediatek/Makefile
+++ b/package/boot/uboot-mediatek/Makefile
@@ -15,18 +15,18 @@ define U-Boot/Default
DEFAULT:=y
endef
-define U-Boot/mt7629
- NAME:=MT7629
- BUILD_SUBTARGET:=mt7629
- UBOOT_CONFIG:=mt7629_rfb
-endef
-
define U-Boot/mt7622
NAME:=MT7622
BUILD_SUBTARGET:=mt7622
UBOOT_CONFIG:=mt7622_rfb
endef
+define U-Boot/mt7623a_unielec_u7623
+ NAME:=UniElec U7623 (mt7623)
+ BUILD_SUBTARGET:=mt7623
+ UBOOT_CONFIG:=mt7623a_unielec_u7623_02
+endef
+
define U-Boot/mt7623n_bpir2
NAME:=Banana Pi R2 (mt7623)
BUILD_SUBTARGET:=mt7623
@@ -34,7 +34,13 @@ define U-Boot/mt7623n_bpir2
UBOOT_CONFIG:=mt7623n_bpir2
endef
-UBOOT_TARGETS := mt7629 mt7622 mt7623n_bpir2
+define U-Boot/mt7629
+ NAME:=MT7629
+ BUILD_SUBTARGET:=mt7629
+ UBOOT_CONFIG:=mt7629_rfb
+endef
+
+UBOOT_TARGETS := mt7629 mt7622 mt7623n_bpir2 mt7623a_unielec_u7623
UBOOT_MAKE_FLAGS += $(UBOOT_IMAGE)