aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-layerscape
diff options
context:
space:
mode:
authorYangbo Lu <yangbo.lu@nxp.com>2020-07-30 13:12:43 +0800
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2021-02-19 20:09:29 +0100
commit2e1ad2473eb02e8e86efa9aa91e138fa759b074e (patch)
tree4e02e7972b3ac91b3b95f008085ca010969a5d77 /package/boot/uboot-layerscape
parent727279333022ad2154e92f38c0b07547587e8239 (diff)
downloadupstream-2e1ad2473eb02e8e86efa9aa91e138fa759b074e.tar.gz
upstream-2e1ad2473eb02e8e86efa9aa91e138fa759b074e.tar.bz2
upstream-2e1ad2473eb02e8e86efa9aa91e138fa759b074e.zip
layerscape: add LX2160ARDB (Rev2.0 silicon) board support
The QorIQ LX2160A reference design board provides a comprehensive platform that enables design and evaluation of the LX2160A processor. - Enables network intelligence with the next generation Datapath (DPPA2) which provides differentiated offload and a rich set of IO, including 10GE, 25GE, 40GE, and PCIe Gen4 - Delivers unprecedented efficiency and new virtualized networks - Supports designs in 5G packet processing, network function virtualization, storage controller, white box switching, network interface cards, and mobile edge computing - Supports all three LX2 family members (16-core LX2160A; 12-core LX2120A; and 8-core LX2080A) Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com> [use AUTORELEASE, add dtb to firmware part] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de> (cherry picked from commit 80dcd14abeed8cd808b92bb307964dbaeb252144)
Diffstat (limited to 'package/boot/uboot-layerscape')
-rw-r--r--package/boot/uboot-layerscape/Makefile12
-rw-r--r--package/boot/uboot-layerscape/files/fsl_lx2160a-rdb-sdboot-uEnv.txt9
-rw-r--r--package/boot/uboot-layerscape/files/fsl_lx2160a-rdb-uEnv.txt9
3 files changed, 30 insertions, 0 deletions
diff --git a/package/boot/uboot-layerscape/Makefile b/package/boot/uboot-layerscape/Makefile
index 98b129f0ff..f02356791d 100644
--- a/package/boot/uboot-layerscape/Makefile
+++ b/package/boot/uboot-layerscape/Makefile
@@ -90,6 +90,16 @@ define U-Boot/fsl_ls2088a-rdb
UBOOT_CONFIG:=ls2088ardb_tfa
endef
+define U-Boot/fsl_lx2160a-rdb
+ NAME:=NXP LX2160ARDB
+ UBOOT_CONFIG:=lx2160ardb_tfa
+endef
+
+define U-Boot/fsl_lx2160a-rdb-sdboot
+ NAME:=NXP LX2160ARDB SD Card Boot
+ UBOOT_CONFIG:=lx2160ardb_tfa
+endef
+
define U-Boot/fsl_ls1021a-twr
NAME:=NXP LS1021ATWR
BUILD_SUBTARGET:=armv7
@@ -126,6 +136,8 @@ UBOOT_TARGETS := \
fsl_ls1088a-rdb \
fsl_ls1088a-rdb-sdboot \
fsl_ls2088a-rdb \
+ fsl_lx2160a-rdb \
+ fsl_lx2160a-rdb-sdboot \
fsl_ls1021a-twr \
fsl_ls1021a-twr-sdboot \
fsl_ls1021a-iot-sdboot
diff --git a/package/boot/uboot-layerscape/files/fsl_lx2160a-rdb-sdboot-uEnv.txt b/package/boot/uboot-layerscape/files/fsl_lx2160a-rdb-sdboot-uEnv.txt
new file mode 100644
index 0000000000..6b4e920c9e
--- /dev/null
+++ b/package/boot/uboot-layerscape/files/fsl_lx2160a-rdb-sdboot-uEnv.txt
@@ -0,0 +1,9 @@
+fdtaddr=0x8f000000
+loadaddr=0x81000000
+bootm_size=0x10000000
+hwconfig=fsl_ddr:bank_intlv=auto
+mc_init=mmc read 80000000 5000 1800;mmc read 80300000 7000 800;fsl_mc start mc 80000000 80300000;mmc read 80400000 6800 800;fsl_mc apply dpl 80400000
+sd_boot=ext4load mmc 0:1 ${loadaddr} fitImage;bootm ${loadaddr}
+bootargs=root=/dev/mmcblk0p2 rw rootwait rootfstype=squashfs,f2fs noinitrd earlycon=pl011,mmio32,0x21c0000 console=ttyAMA0,115200
+bootcmd=echo starting openwrt ...;run mc_init;run sd_boot
+bootdelay=3
diff --git a/package/boot/uboot-layerscape/files/fsl_lx2160a-rdb-uEnv.txt b/package/boot/uboot-layerscape/files/fsl_lx2160a-rdb-uEnv.txt
new file mode 100644
index 0000000000..08757b4460
--- /dev/null
+++ b/package/boot/uboot-layerscape/files/fsl_lx2160a-rdb-uEnv.txt
@@ -0,0 +1,9 @@
+fdtaddr=0x8f000000
+loadaddr=0x81000000
+bootm_size=0x10000000
+hwconfig=fsl_ddr:bank_intlv=auto
+mc_init=sf probe 0:0;sf read 80000000 a00000 300000;sf read 80300000 e00000 100000;fsl_mc start mc 80000000 80300000;sf read 80400000 d00000 100000;fsl_mc apply dpl 80400000
+xspi_boot=sf probe 0:0;sf read $fdtaddr f00000 100000;sf read $loadaddr 1000000 1000000;bootm $loadaddr - $fdtaddr
+bootargs=root=/dev/mtdblock9 rootfstype=squashfs,jffs2 noinitrd earlycon=pl011,mmio32,0x21c0000 console=ttyAMA0,115200 mtdparts=20c0000.spi-0:1m(bl2),4m(fip),1m(u-boot-env),4m(reserved-1),3m(mc),1m(dpl),1m(dpc),1m(dtb),16m(kernel),32m(rootfs),49m@0xf00000(firmware)
+bootcmd=echo starting openwrt ...;run mc_init;run xspi_boot
+bootdelay=3