aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-layerscape
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2017-01-27 16:06:31 +0100
committerJo-Philipp Wich <jo@mein.io>2017-01-27 16:53:31 +0100
commitc6502ce3bb87b6a6a85209d3e67736bd2db21bc7 (patch)
tree7af829172459e805158e43caf9f2f30a51559852 /package/boot/uboot-layerscape
parent237bd361352446669d4058e423f5e1b27c930004 (diff)
downloadupstream-c6502ce3bb87b6a6a85209d3e67736bd2db21bc7.tar.gz
upstream-c6502ce3bb87b6a6a85209d3e67736bd2db21bc7.tar.bz2
upstream-c6502ce3bb87b6a6a85209d3e67736bd2db21bc7.zip
layerscape: put u-boot and ucode images into image staging directory
Do not put the u-boot and ucode images into the kernel build directory as this directory might get removed after kernel updates while the u-boot packages InstallDev recipe is not getting re-executed because it is still considered current, leading to image build failures later on due to missing images. To ensure that built bootloader images persist over kernel version updates in the buildroot, put them into the new STAGING_DIR_IMAGE directory. Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'package/boot/uboot-layerscape')
-rw-r--r--package/boot/uboot-layerscape/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/boot/uboot-layerscape/Makefile b/package/boot/uboot-layerscape/Makefile
index f0ab726534..ac3d7aba86 100644
--- a/package/boot/uboot-layerscape/Makefile
+++ b/package/boot/uboot-layerscape/Makefile
@@ -49,7 +49,8 @@ UBOOT_TARGETS := \
ls1012ardb
define Build/InstallDev
- $(INSTALL_DATA) $(PKG_BUILD_DIR)/$(UBOOT_IMAGE) $(KERNEL_BUILD_DIR)/$(BUILD_VARIANT)-64b-uboot.bin
+ $(INSTALL_DIR) $(STAGING_DIR_IMAGE)
+ $(INSTALL_DATA) $(PKG_BUILD_DIR)/$(UBOOT_IMAGE) $(STAGING_DIR_IMAGE)/$(BUILD_VARIANT)-64b-uboot.bin
endef
define Package/u-boot/install/default