aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-layerscape
diff options
context:
space:
mode:
authorBiwen Li <biwen.li@nxp.com>2018-11-02 18:30:57 +0800
committerHauke Mehrtens <hauke@hauke-m.de>2018-12-18 20:17:23 +0100
commit328530c6e7569d7be24e3524483f4453910003e9 (patch)
tree90ec1f99796fb88ebffb69380eb5adc0e60f34b8 /package/boot/uboot-layerscape
parent0a827ebd2fa3c7dc210aff0a30d0dc1d536ed89c (diff)
downloadupstream-328530c6e7569d7be24e3524483f4453910003e9.tar.gz
upstream-328530c6e7569d7be24e3524483f4453910003e9.tar.bz2
upstream-328530c6e7569d7be24e3524483f4453910003e9.zip
layerscape: add LS1021AIOT board support
The LS1021A-IoT gateway reference design based on the QorIQ LS1021A processor is a purpose-built, small footprint hardware platform with a wide array of high-speed connectivity and low-speed serial interfaces to support secure delivery of IoT services for home, business or other commercial location. - Combines standards-based, open source software with a feature-rich IoT gateway design to establish a common, open framework for secured IoT service delivery and management. - Provides a wide assortment of high-speed and serial-based connectivity in a compact, highly secure design. - High efficiency through the use of the Arm-based QorIQ LS1021A embedded processor. Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com> Signed-off-by: Biwen Li <biwen.li@nxp.com>
Diffstat (limited to 'package/boot/uboot-layerscape')
-rw-r--r--package/boot/uboot-layerscape/Makefile12
-rw-r--r--package/boot/uboot-layerscape/files/ls1021aiot-sdboot-uEnv.txt8
2 files changed, 19 insertions, 1 deletions
diff --git a/package/boot/uboot-layerscape/Makefile b/package/boot/uboot-layerscape/Makefile
index 39dc6c76d1..911d9696e6 100644
--- a/package/boot/uboot-layerscape/Makefile
+++ b/package/boot/uboot-layerscape/Makefile
@@ -92,6 +92,15 @@ define U-Boot/ls1021atwr-sdboot
ENV_SIZE:=0x20000
endef
+define U-Boot/ls1021aiot-sdboot
+ NAME:=NXP LS1021AIOT SD Card Boot
+ BUILD_SUBTARGET:=armv7
+ UBOOT_CONFIG:=ls1021aiot_sdcard
+ UBOOT_IMAGE:=u-boot-with-spl-pbl.bin
+ ENV_SIZE:=0x2000
+endef
+
+
UBOOT_TARGETS := \
ls1012ardb \
ls1012afrwy \
@@ -103,7 +112,8 @@ UBOOT_TARGETS := \
ls1088ardb-sdboot \
ls2088ardb \
ls1021atwr \
- ls1021atwr-sdboot
+ ls1021atwr-sdboot \
+ ls1021aiot-sdboot
define Build/InstallDev
$(INSTALL_DIR) $(STAGING_DIR_IMAGE)
diff --git a/package/boot/uboot-layerscape/files/ls1021aiot-sdboot-uEnv.txt b/package/boot/uboot-layerscape/files/ls1021aiot-sdboot-uEnv.txt
new file mode 100644
index 0000000000..7772daa100
--- /dev/null
+++ b/package/boot/uboot-layerscape/files/ls1021aiot-sdboot-uEnv.txt
@@ -0,0 +1,8 @@
+fdtaddr=0x8f000000
+loadaddr=0x81000000
+fdt_high=0xffffffff
+initrd_high=0xffffffff
+sd_boot=mmc read ${fdtaddr} 7800 800;mmc read ${loadaddr} 8000 8000;bootm ${loadaddr} - ${fdtaddr}
+bootargs=root=/dev/mmcblk0p1 rw rootwait rootfstype=ext4 noinitrd earlycon=uart8250,mmio,0x21c0500 console=ttyS0,115200
+bootcmd=echo starting openwrt ...;run sd_boot
+bootdelay=3