aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-layerscape
diff options
context:
space:
mode:
authorYangbo Lu <yangbo.lu@nxp.com>2017-06-29 11:19:07 +0800
committerJohn Crispin <john@phrozen.org>2017-10-07 23:13:22 +0200
commit806624add541bd828516a58aab20ae19ae9e431f (patch)
treee5bb450e4b18defde11492f2a3578f1ad04e8163 /package/boot/uboot-layerscape
parent4c89f2fcf8f6579257342cfca47293c0ac16fe86 (diff)
downloadupstream-806624add541bd828516a58aab20ae19ae9e431f.tar.gz
upstream-806624add541bd828516a58aab20ae19ae9e431f.tar.bz2
upstream-806624add541bd828516a58aab20ae19ae9e431f.zip
layerscape: rename subtargets and update makefile files
Rename subtargets 32b/64b with armv8_32b/armv8_64b which are more proper, and update makefile files. There also will be other subtargets added in the future, like armv7. Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
Diffstat (limited to 'package/boot/uboot-layerscape')
-rw-r--r--package/boot/uboot-layerscape/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/boot/uboot-layerscape/Makefile b/package/boot/uboot-layerscape/Makefile
index f98205335b..f933141e89 100644
--- a/package/boot/uboot-layerscape/Makefile
+++ b/package/boot/uboot-layerscape/Makefile
@@ -22,7 +22,7 @@ include $(INCLUDE_DIR)/package.mk
define U-Boot/Default
BUILD_TARGET:=layerscape
- BUILD_SUBTARGET:=64b
+ BUILD_SUBTARGET:=armv8_64b
BUILD_DEVICES:=$(1)
UBOOT_IMAGE:=u-boot-dtb.bin
HIDDEN:=y
@@ -50,7 +50,7 @@ UBOOT_TARGETS := \
define Build/InstallDev
$(INSTALL_DIR) $(STAGING_DIR_IMAGE)
- $(INSTALL_DATA) $(PKG_BUILD_DIR)/$(UBOOT_IMAGE) $(STAGING_DIR_IMAGE)/$(BUILD_VARIANT)-64b-uboot.bin
+ $(INSTALL_DATA) $(PKG_BUILD_DIR)/$(UBOOT_IMAGE) $(STAGING_DIR_IMAGE)/$(BUILD_VARIANT)-$(BUILD_SUBTARGET)-uboot.bin
endef
define Package/u-boot/install/default