aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-layerscape/Makefile
diff options
context:
space:
mode:
authorBiwen Li <biwen.li@nxp.com>2019-05-06 11:26:09 +0800
committerPetr Štetiar <ynezz@true.cz>2019-06-06 15:40:09 +0200
commitc07d3302b3cd4fc50ff380239f4541df7526df82 (patch)
tree42d639418c68700fa1609458f432aa8fa75d22c3 /package/boot/uboot-layerscape/Makefile
parent17dcbe1b8e2b7074ab1822f117e48a5c04997e4a (diff)
downloadupstream-c07d3302b3cd4fc50ff380239f4541df7526df82.tar.gz
upstream-c07d3302b3cd4fc50ff380239f4541df7526df82.tar.bz2
upstream-c07d3302b3cd4fc50ff380239f4541df7526df82.zip
layerscape: convert to use TF-A for firmware
This patch is to convert to use TF-A for firmware. - Use un-swapped rcw since swapping will be done in TF-A. - Use u-boot with TF-A defconfig. - Rework memory map for TF-A introduction. Signed-off-by: Biwen Li <biwen.li@nxp.com> Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
Diffstat (limited to 'package/boot/uboot-layerscape/Makefile')
-rw-r--r--package/boot/uboot-layerscape/Makefile24
1 files changed, 12 insertions, 12 deletions
diff --git a/package/boot/uboot-layerscape/Makefile b/package/boot/uboot-layerscape/Makefile
index 3630ecf120..ddf71bd986 100644
--- a/package/boot/uboot-layerscape/Makefile
+++ b/package/boot/uboot-layerscape/Makefile
@@ -29,52 +29,52 @@ endef
define U-Boot/ls1012ardb
NAME:=NXP LS1012ARDB
- UBOOT_CONFIG:=ls1012ardb_qspi
+ UBOOT_CONFIG:=ls1012ardb_tfa
ENV_SIZE:=0x40000
endef
define U-Boot/ls1012afrwy
NAME:=NXP LS1012AFRWY
- UBOOT_CONFIG:=ls1012afrwy_qspi
+ UBOOT_CONFIG:=ls1012afrwy_tfa
ENV_SIZE:=0x10000
endef
define U-Boot/ls1043ardb
NAME:=NXP LS1043ARDB
- ENV_SIZE:=0x20000
+ UBOOT_CONFIG:=ls1043ardb_tfa
endef
define U-Boot/ls1043ardb-sdboot
NAME:=NXP LS1043ARDB SD Card Boot
- UBOOT_CONFIG:=ls1043ardb_sdcard
- UBOOT_IMAGE:=u-boot-with-spl-pbl.bin
+ UBOOT_CONFIG:=ls1043ardb_tfa
endef
+
define U-Boot/ls1046ardb
NAME:=NXP LS1046ARDB
- UBOOT_CONFIG:=ls1046ardb_qspi
+ UBOOT_CONFIG:=ls1046ardb_tfa
endef
define U-Boot/ls1046ardb-sdboot
NAME:=NXP LS1046ARDB SD Card Boot
- UBOOT_CONFIG:=ls1046ardb_sdcard
- UBOOT_IMAGE:=u-boot-with-spl-pbl.bin
+ UBOOT_CONFIG:=ls1046ardb_tfa
endef
+
define U-Boot/ls1088ardb
NAME:=NXP LS1088ARDB
- UBOOT_CONFIG:=ls1088ardb_qspi
+ UBOOT_CONFIG:=ls1088ardb_tfa
endef
+
define U-Boot/ls1088ardb-sdboot
NAME:=NXP LS1088ARDB SD Card Boot
- UBOOT_CONFIG:=ls1088ardb_sdcard_qspi
- UBOOT_IMAGE:=u-boot-with-spl.bin
+ UBOOT_CONFIG:=ls1088ardb_tfa
endef
define U-Boot/ls2088ardb
NAME:=NXP LS2088ARDB
- UBOOT_CONFIG:=ls2080ardb
+ UBOOT_CONFIG:=ls2088ardb_tfa
endef
define U-Boot/ls1021atwr