aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-layerscape/Makefile
diff options
context:
space:
mode:
authorYangbo Lu <yangbo.lu@nxp.com>2017-07-03 10:48:27 +0800
committerJohn Crispin <john@phrozen.org>2017-10-07 23:13:22 +0200
commit2e2203ff72fd1556bab2c32e808ce7bb79a9858c (patch)
tree607f010eaac6a2830d92ac07e7ae8ab566b5e049 /package/boot/uboot-layerscape/Makefile
parent806624add541bd828516a58aab20ae19ae9e431f (diff)
downloadupstream-2e2203ff72fd1556bab2c32e808ce7bb79a9858c.tar.gz
upstream-2e2203ff72fd1556bab2c32e808ce7bb79a9858c.tar.bz2
upstream-2e2203ff72fd1556bab2c32e808ce7bb79a9858c.zip
layerscape: update packages with LSDK git trees
NXP Layerscape LSDK had set up its own open source web site and github for release. https://lsdk.github.io https://github.com/qoriq-open-source This patch is to update rcw/fman_ucode/u-boot packages with LSDK git trees. Also add some patches of packages to support LEDE. Since ARMv8 32-bit u-boot images are same with ARMv8 64-bit images but 64-bit toolchain couldn't be used for 32-bit targets, we still use a private tree for ARMv8 32-bit u-boot images. This is in plan to move this private tree to NXP Layerscape github. Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
Diffstat (limited to 'package/boot/uboot-layerscape/Makefile')
-rw-r--r--package/boot/uboot-layerscape/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/package/boot/uboot-layerscape/Makefile b/package/boot/uboot-layerscape/Makefile
index f933141e89..01ebd6e511 100644
--- a/package/boot/uboot-layerscape/Makefile
+++ b/package/boot/uboot-layerscape/Makefile
@@ -9,13 +9,13 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=uboot-layerscape
-PKG_VERSION:=v1.0
+PKG_VERSION:=2017.09
PKG_RELEASE:=1
PKG_SOURCE_PROTO:=git
-PKG_MIRROR_HASH:=462fea9bdf03ec4bc23f2f1bb3917c2ec57017eca1e11b8a609bf60cd51a94e7
-PKG_SOURCE_URL:=https://github.com/fsl-jyt/u-boot.git
-PKG_SOURCE_VERSION:=69b5ea576a2b0448391a910114d6c05859bf78d0
+PKG_SOURCE_URL:=https://github.com/qoriq-open-source/u-boot.git
+PKG_SOURCE_VERSION:=503eff00a7119d2690a662ed64e83e4782b7d3d9
+PKG_MIRROR_HASH:=67dbf765b91a5f181e693bd87b6e9521ffeec163c7c037f71b19b3d8715dc32a
include $(INCLUDE_DIR)/u-boot.mk
include $(INCLUDE_DIR)/package.mk
@@ -40,7 +40,6 @@ endef
define U-Boot/ls1012ardb
NAME:=NXP ls1012ardb 64b Dev Board
UBOOT_CONFIG:=ls1012ardb_qspi
- UBOOT_IMAGE:=u-boot-swap.bin
endef
UBOOT_TARGETS := \