aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-layerscape/Makefile
diff options
context:
space:
mode:
authorYangbo Lu <yangbo.lu@nxp.com>2018-07-17 17:42:47 +0800
committerHauke Mehrtens <hauke@hauke-m.de>2018-09-22 21:20:56 +0200
commitad1dbc0ca304686a7f826528e674620791f34584 (patch)
treec33516cb3780c225e9dfe2e5cb48392722ec49f8 /package/boot/uboot-layerscape/Makefile
parentdcf57c766acc5224e05f62cf5fae2d965abace59 (diff)
downloadupstream-ad1dbc0ca304686a7f826528e674620791f34584.tar.gz
upstream-ad1dbc0ca304686a7f826528e674620791f34584.tar.bz2
upstream-ad1dbc0ca304686a7f826528e674620791f34584.zip
layerscape: add u-boot environment support for OpenWrt boot
This patch is to implement u-boot environment txt files to support OpenWrt boot for all layerscape devices. Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
Diffstat (limited to 'package/boot/uboot-layerscape/Makefile')
-rw-r--r--package/boot/uboot-layerscape/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/package/boot/uboot-layerscape/Makefile b/package/boot/uboot-layerscape/Makefile
index 9e4079e386..ffa392cd6e 100644
--- a/package/boot/uboot-layerscape/Makefile
+++ b/package/boot/uboot-layerscape/Makefile
@@ -24,20 +24,24 @@ define U-Boot/Default
BUILD_SUBTARGET:=armv8_64b
BUILD_DEVICES:=$(1)
UBOOT_IMAGE:=u-boot-dtb.bin
+ ENV_SIZE:=0x2000
endef
define U-Boot/ls1012ardb
NAME:=NXP LS1012ARDB
UBOOT_CONFIG:=ls1012ardb_qspi
+ ENV_SIZE:=0x40000
endef
define U-Boot/ls1012afrdm
NAME:=NXP LS1012AFRDM
UBOOT_CONFIG:=ls1012afrdm_qspi
+ ENV_SIZE:=0x40000
endef
define U-Boot/ls1043ardb
NAME:=NXP LS1043ARDB
+ ENV_SIZE:=0x20000
endef
define U-Boot/ls1046ardb
@@ -67,6 +71,9 @@ define Build/InstallDev
$(INSTALL_DIR) $(STAGING_DIR_IMAGE)
$(INSTALL_DATA) $(PKG_BUILD_DIR)/$(UBOOT_IMAGE) \
$(STAGING_DIR_IMAGE)/$(BUILD_VARIANT)-uboot.bin
+ $(PKG_BUILD_DIR)/tools/mkenvimage -s $(ENV_SIZE) \
+ -o $(STAGING_DIR_IMAGE)/$(BUILD_VARIANT)-uboot-env.bin \
+ files/$(BUILD_VARIANT)-uEnv.txt
endef
define Package/u-boot/install/default