aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-layerscape-armv8_32b
diff options
context:
space:
mode:
authorYangbo Lu <yangbo.lu@nxp.com>2018-07-17 17:42:47 +0800
committerHauke Mehrtens <hauke@hauke-m.de>2018-09-22 21:20:56 +0200
commitad1dbc0ca304686a7f826528e674620791f34584 (patch)
treec33516cb3780c225e9dfe2e5cb48392722ec49f8 /package/boot/uboot-layerscape-armv8_32b
parentdcf57c766acc5224e05f62cf5fae2d965abace59 (diff)
downloadupstream-ad1dbc0ca304686a7f826528e674620791f34584.tar.gz
upstream-ad1dbc0ca304686a7f826528e674620791f34584.tar.bz2
upstream-ad1dbc0ca304686a7f826528e674620791f34584.zip
layerscape: add u-boot environment support for OpenWrt boot
This patch is to implement u-boot environment txt files to support OpenWrt boot for all layerscape devices. Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
Diffstat (limited to 'package/boot/uboot-layerscape-armv8_32b')
-rw-r--r--package/boot/uboot-layerscape-armv8_32b/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/package/boot/uboot-layerscape-armv8_32b/Makefile b/package/boot/uboot-layerscape-armv8_32b/Makefile
index 415d9bdbea..b9cec52174 100644
--- a/package/boot/uboot-layerscape-armv8_32b/Makefile
+++ b/package/boot/uboot-layerscape-armv8_32b/Makefile
@@ -29,27 +29,32 @@ define Package/uboot-layerscape-armv8_32b/Config
TITLE:=$(2)
DEPENDS:=@TARGET_layerscape_armv8_32b
CONFIG:=$(3)
+ ENV_SIZE:=$(4)
endef
endef
define Package/uboot-layerscape-armv8_32b/ls1012ardb
TITLE:=U-Boot image for NXP LS1012ARDB
CONFIG:=ls1012ardb-uboot.bin
+ ENV_SIZE:=0x40000
endef
define Package/uboot-layerscape-armv8_32b/ls1012afrdm
TITLE:=U-Boot image for NXP LS1012FRDM
CONFIG:=ls1012afrdm-uboot.bin
+ ENV_SIZE:=0x40000
endef
define Package/uboot-layerscape-armv8_32b/ls1043ardb
TITLE:=U-Boot image for NXP LS1043ARDB
CONFIG:=ls1043ardb-uboot.bin
+ ENV_SIZE:=0x20000
endef
define Package/uboot-layerscape-armv8_32b/ls1046ardb
TITLE:=U-Boot image for NXP LS1046ARDB
CONFIG:=ls1046ardb-uboot.bin
+ ENV_SIZE:=0x2000
endef
define Build/Compile
@@ -59,6 +64,9 @@ define Package/uboot-layerscape-armv8_32b/Install
define Package/u-boot-$(1)-image/install
$(INSTALL_DIR) $(STAGING_DIR_IMAGE)
$(CP) $(PKG_BUILD_DIR)/$(CONFIG) $(STAGING_DIR_IMAGE)/
+ $(PKG_BUILD_DIR)/tools/mkenvimage -s $(ENV_SIZE) \
+ -o $(STAGING_DIR_IMAGE)/$(1)-uboot-env.bin \
+ ../uboot-layerscape/files/$(1)-uEnv.txt
endef
endef
@@ -70,7 +78,7 @@ UBOOTS := \
$(foreach u,$(UBOOTS), \
$(eval $(Package/uboot-layerscape-armv8_32b/$(u))) \
- $(eval $(call Package/uboot-layerscape-armv8_32b/Config,$(u),$(TITLE),$(CONFIG))) \
+ $(eval $(call Package/uboot-layerscape-armv8_32b/Config,$(u),$(TITLE),$(CONFIG),$(ENV_SIZE))) \
$(eval $(call Package/uboot-layerscape-armv8_32b/Install,$(u))) \
$(eval $(call BuildPackage,u-boot-$(u)-image)) \
)