aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-layerscape-32b/Makefile
diff options
context:
space:
mode:
authorYangbo Lu <yangbo.lu@nxp.com>2017-06-29 11:19:07 +0800
committerJohn Crispin <john@phrozen.org>2017-10-07 23:13:22 +0200
commit806624add541bd828516a58aab20ae19ae9e431f (patch)
treee5bb450e4b18defde11492f2a3578f1ad04e8163 /package/boot/uboot-layerscape-32b/Makefile
parent4c89f2fcf8f6579257342cfca47293c0ac16fe86 (diff)
downloadupstream-806624add541bd828516a58aab20ae19ae9e431f.tar.gz
upstream-806624add541bd828516a58aab20ae19ae9e431f.tar.bz2
upstream-806624add541bd828516a58aab20ae19ae9e431f.zip
layerscape: rename subtargets and update makefile files
Rename subtargets 32b/64b with armv8_32b/armv8_64b which are more proper, and update makefile files. There also will be other subtargets added in the future, like armv7. Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
Diffstat (limited to 'package/boot/uboot-layerscape-32b/Makefile')
-rw-r--r--package/boot/uboot-layerscape-32b/Makefile51
1 files changed, 0 insertions, 51 deletions
diff --git a/package/boot/uboot-layerscape-32b/Makefile b/package/boot/uboot-layerscape-32b/Makefile
deleted file mode 100644
index 2ea03e5f4f..0000000000
--- a/package/boot/uboot-layerscape-32b/Makefile
+++ /dev/null
@@ -1,51 +0,0 @@
-#
-# Copyright (C) 2016 Jiang Yutang <jiangyutang1978@gmail.com>
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=uboot-layerscape-32bit
-PKG_VERSION:=v1.0
-PKG_RELEASE:=1
-
-PKG_SOURCE_PROTO:=git
-PKG_MIRROR_HASH:=a29edbeddde4b3007ac349c2a5ee434719049ac4753e459dbb1bab21e1c585da
-PKG_SOURCE_URL:=https://github.com/fsl-jyt/uboot-ls-32b.git
-PKG_SOURCE_VERSION:=6476195551ea83193afd06d0c441483c04729c8d
-
-PKG_LICENSE:=GPL-2.0 GPL-2.0+
-PKG_LICENSE_FILES:=Licenses/README
-
-PKG_MAINTAINER:=Jiang Yutang <jiangyutang1978@gmail.com>
-
-include $(INCLUDE_DIR)/package.mk
-include $(INCLUDE_DIR)/kernel.mk
-
-define Package/uboot-layerscape-32b
- SECTION:=boot
- CATEGORY:=Boot Loaders
- DEPENDS:=@TARGET_layerscape_32b
- TITLE:=32-bit U-Boot for Layerscape boards
- DEFAULT:=y
- HIDDEN:=1
-endef
-
-define Build/Configure
-
-endef
-
-define Build/Compile
-
-endef
-
-define Build/InstallDev
- $(INSTALL_DIR) $(STAGING_DIR_IMAGE)
- $(CP) $(PKG_BUILD_DIR)/ls1043ardb-uboot.bin $(STAGING_DIR_IMAGE)/ls1043ardb-32b-uboot.bin
- $(CP) $(PKG_BUILD_DIR)/ls1046ardb-uboot.bin $(STAGING_DIR_IMAGE)/ls1046ardb-32b-uboot.bin
- $(CP) $(PKG_BUILD_DIR)/ls1012ardb-uboot.bin.swap $(STAGING_DIR_IMAGE)/ls1012ardb-32b-uboot.bin
-endef
-
-$(eval $(call BuildPackage,uboot-layerscape-32b))