aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-lantiq
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2017-12-31 11:48:15 +0100
committerMathias Kresin <dev@kresin.me>2018-02-20 19:25:17 +0100
commit627a28eb09c0aa3471466850dfde6a063481a4f6 (patch)
treeb3000e5b455ef6f7887f1db955827c50f76d216b /package/boot/uboot-lantiq
parent6112abf186bfe6dabd440a9d1f8f071178cce9a2 (diff)
downloadupstream-627a28eb09c0aa3471466850dfde6a063481a4f6.tar.gz
upstream-627a28eb09c0aa3471466850dfde6a063481a4f6.tar.bz2
upstream-627a28eb09c0aa3471466850dfde6a063481a4f6.zip
lantiq: rename gphy firmware
Rename the gphy firmware to match the name requested by kernel 4.14 and update the devicetree source files to use the new name. Update the u-boot lantiq Makefile to be compatible with the new names as well. Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'package/boot/uboot-lantiq')
-rw-r--r--package/boot/uboot-lantiq/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/package/boot/uboot-lantiq/Makefile b/package/boot/uboot-lantiq/Makefile
index 5493737d3f..55038fdf65 100644
--- a/package/boot/uboot-lantiq/Makefile
+++ b/package/boot/uboot-lantiq/Makefile
@@ -353,17 +353,17 @@ UBOOT_TARGETS:= \
define CompressVR9Firmware
$(STAGING_DIR_HOST)/bin/lzma e \
- $(FIRMWARE_LANTIQ_SOURCE)/vr9_phy$(1)_a$(2)x.bin \
+ $(FIRMWARE_LANTIQ_SOURCE)/xrx200_phy$(1)_a$(2)$(3).bin \
$(PKG_BUILD_DIR)/arch/mips/cpu/mips32/vrx200/fw_phy$(1)_a$(2)x.blob
endef
define Build/Prepare
$(call Build/Prepare/Default)
mkdir -p $(PKG_BUILD_DIR)/arch/mips/cpu/mips32/vrx200/
- $(call CompressVR9Firmware,11g,1)
- $(call CompressVR9Firmware,11g,2)
- $(call CompressVR9Firmware,22f,1)
- $(call CompressVR9Firmware,22f,2)
+ $(call CompressVR9Firmware,11g,1,4)
+ $(call CompressVR9Firmware,11g,2,2)
+ $(call CompressVR9Firmware,22f,1,4)
+ $(call CompressVR9Firmware,22f,2,2)
endef
UBOOT_MAKE_FLAGS :=