aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-lantiq/patches/0009-net-switchlib-add-framework-for-ethernet-switch-driv.patch
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2014-04-22 08:08:19 +0000
committerJohn Crispin <john@openwrt.org>2014-04-22 08:08:19 +0000
commit03a777c29388b974fde3be10f7b82a9610699428 (patch)
tree557155974382cf222933898e8fa841fa9d5e75b6 /package/boot/uboot-lantiq/patches/0009-net-switchlib-add-framework-for-ethernet-switch-driv.patch
parent686a17e6479a3185147e800dc1a7ffc9ae1bfbf0 (diff)
downloadupstream-03a777c29388b974fde3be10f7b82a9610699428.tar.gz
upstream-03a777c29388b974fde3be10f7b82a9610699428.tar.bz2
upstream-03a777c29388b974fde3be10f7b82a9610699428.zip
Refresh patches
Refresh uboot-lantiq patches. Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com> SVN-Revision: 40546
Diffstat (limited to 'package/boot/uboot-lantiq/patches/0009-net-switchlib-add-framework-for-ethernet-switch-driv.patch')
-rw-r--r--package/boot/uboot-lantiq/patches/0009-net-switchlib-add-framework-for-ethernet-switch-driv.patch16
1 files changed, 0 insertions, 16 deletions
diff --git a/package/boot/uboot-lantiq/patches/0009-net-switchlib-add-framework-for-ethernet-switch-driv.patch b/package/boot/uboot-lantiq/patches/0009-net-switchlib-add-framework-for-ethernet-switch-driv.patch
index e25df312e1..de6f51bb09 100644
--- a/package/boot/uboot-lantiq/patches/0009-net-switchlib-add-framework-for-ethernet-switch-driv.patch
+++ b/package/boot/uboot-lantiq/patches/0009-net-switchlib-add-framework-for-ethernet-switch-driv.patch
@@ -10,8 +10,6 @@ setup code for switch devices across different boards.
Signed-off-by: Daniel Schwierzeck <daniel.schwierzeck@gmail.com>
Cc: Joe Hershberger <joe.hershberger@gmail.com>
-diff --git a/Makefile b/Makefile
-index dc04179..6ee9a3c 100644
--- a/Makefile
+++ b/Makefile
@@ -280,6 +280,7 @@ LIBS-y += drivers/mtd/ubi/libubi.o
@@ -22,9 +20,6 @@ index dc04179..6ee9a3c 100644
LIBS-y += drivers/pci/libpci.o
LIBS-y += drivers/pcmcia/libpcmcia.o
LIBS-y += drivers/power/libpower.o \
-diff --git a/drivers/net/switch/Makefile b/drivers/net/switch/Makefile
-new file mode 100644
-index 0000000..31719d8
--- /dev/null
+++ b/drivers/net/switch/Makefile
@@ -0,0 +1,30 @@
@@ -58,9 +53,6 @@ index 0000000..31719d8
+sinclude $(obj).depend
+
+#########################################################################
-diff --git a/drivers/net/switch/switch.c b/drivers/net/switch/switch.c
-new file mode 100644
-index 0000000..0e1d6b7
--- /dev/null
+++ b/drivers/net/switch/switch.c
@@ -0,0 +1,62 @@
@@ -126,9 +118,6 @@ index 0000000..0e1d6b7
+
+ return NULL;
+}
-diff --git a/include/switch.h b/include/switch.h
-new file mode 100644
-index 0000000..4a7ae63
--- /dev/null
+++ b/include/switch.h
@@ -0,0 +1,102 @@
@@ -234,8 +223,6 @@ index 0000000..4a7ae63
+
+#endif /* __SWITCH_H */
+
-diff --git a/net/eth.c b/net/eth.c
-index c96e767..03ecc1c 100644
--- a/net/eth.c
+++ b/net/eth.c
@@ -10,6 +10,7 @@
@@ -255,6 +242,3 @@ index c96e767..03ecc1c 100644
eth_env_init(bis);
/*
---
-1.8.3.2
-