aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-kirkwood/Makefile
diff options
context:
space:
mode:
authorPawel Dembicki <paweldembicki@gmail.com>2020-05-09 22:08:02 +0200
committerPetr Štetiar <ynezz@true.cz>2020-07-08 16:07:05 +0200
commit4c2e475842fa4d1c2f1d8508d526fefac1a2948c (patch)
tree1cdc88b2f3ee460105c524b873e332ab0f921e0e /package/boot/uboot-kirkwood/Makefile
parentba59021d64d52a5ec3e75b9701d65f940c33a670 (diff)
downloadupstream-4c2e475842fa4d1c2f1d8508d526fefac1a2948c.tar.gz
upstream-4c2e475842fa4d1c2f1d8508d526fefac1a2948c.tar.bz2
upstream-4c2e475842fa4d1c2f1d8508d526fefac1a2948c.zip
uboot-kirkwood: add support for Zyxel NSA310S
This patch modifies the u-boot config for the Zyxel NSA310S to work with OpenWrt. Signed-off-by: Pawel Dembicki <paweldembicki@gmail.com>
Diffstat (limited to 'package/boot/uboot-kirkwood/Makefile')
-rw-r--r--package/boot/uboot-kirkwood/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/package/boot/uboot-kirkwood/Makefile b/package/boot/uboot-kirkwood/Makefile
index c1b33b4a82..d2cbc1041b 100644
--- a/package/boot/uboot-kirkwood/Makefile
+++ b/package/boot/uboot-kirkwood/Makefile
@@ -59,6 +59,11 @@ define U-Boot/nsa310
BUILD_DEVICES:=zyxel_nsa310b
endef
+define U-Boot/nsa310s
+ NAME:=Zyxel NSA310S
+ BUILD_DEVICES:=zyxel_nsa310s
+endef
+
define U-Boot/nsa325
NAME:=Zyxel NSA325v1 and v2
BUILD_DEVICES:=zyxel_nsa325
@@ -85,6 +90,7 @@ UBOOT_TARGETS := \
ib62x0 ib62x0_second_stage \
iconnect iconnect_second_stage \
nsa310 \
+ nsa310s \
nsa325 \
pogo_e02 pogo_e02_second_stage \
pogoplugv4