aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-kirkwood/Makefile
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2014-05-23 08:17:01 +0000
committerLuka Perkov <luka@openwrt.org>2014-05-23 08:17:01 +0000
commitd3fc4fbd74dcd4dbeaa29d222337eeb6c187a4fd (patch)
tree17c9660df2f09ff138ea72327fc0a3df1848cb69 /package/boot/uboot-kirkwood/Makefile
parent3bb20dedcd822ad5ed44e8bb2bcff7b15d447eef (diff)
downloadupstream-d3fc4fbd74dcd4dbeaa29d222337eeb6c187a4fd.tar.gz
upstream-d3fc4fbd74dcd4dbeaa29d222337eeb6c187a4fd.tar.bz2
upstream-d3fc4fbd74dcd4dbeaa29d222337eeb6c187a4fd.zip
uboot-kirkwood: re-add Pogoplug E02 support
This patch modifies the u-boot config for the Pogoplug E02 to work with OpenWrt. It also enables building a second stage bootloader image. Signed-off-by: Felix Kaechele <heffer@fedoraproject.org> SVN-Revision: 40828
Diffstat (limited to 'package/boot/uboot-kirkwood/Makefile')
-rw-r--r--package/boot/uboot-kirkwood/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/package/boot/uboot-kirkwood/Makefile b/package/boot/uboot-kirkwood/Makefile
index 45046690ff..0f0314319f 100644
--- a/package/boot/uboot-kirkwood/Makefile
+++ b/package/boot/uboot-kirkwood/Makefile
@@ -61,6 +61,10 @@ define uboot/pogo_e02
TITLE:=U-Boot for Cloud Engines Pogoplug E02
endef
+define uboot/pogo_e02_second_stage
+ TITLE:=second stage U-Boot for Cloud Engines Pogoplug E02
+endef
+
define uboot/sheevaplug
TITLE:=U-Boot for SheevaPlug
endef
@@ -70,7 +74,7 @@ UBOOTS:= \
goflexhome \
ib62x0 ib62x0_second_stage \
iconnect iconnect_second_stage \
- pogo_e02 \
+ pogo_e02 pogo_e02_second_stage \
sheevaplug
define Package/uboot/template