aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-imx
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2022-07-12 09:22:15 +0200
committerPetr Štetiar <ynezz@true.cz>2022-07-12 09:25:43 +0200
commit64fb5ae67ab0840d3da75f101abc2af0aeed2365 (patch)
treed5bafb8053c4457219ed06d50ab51919c5bae104 /package/boot/uboot-imx
parentae07b9cc6198ac7f68a52dc6f3da5c86d0393903 (diff)
downloadupstream-64fb5ae67ab0840d3da75f101abc2af0aeed2365.tar.gz
upstream-64fb5ae67ab0840d3da75f101abc2af0aeed2365.tar.bz2
upstream-64fb5ae67ab0840d3da75f101abc2af0aeed2365.zip
uboot-imx: pico-pi-imx7d: fix wrong make flags overriding
Buidbots are currently choking on the following compile error: In file included from tools/aisimage.c:9: include/image.h:1133:12: fatal error: openssl/evp.h: No such file or directory # include <openssl/evp.h> ^~~~~~~~~~~~~~~ compilation terminated. This is caused by a complete overriding of make flags which are provided correctly in `UBOOT_MAKE_FLAGS` variable, but currently overriden instead of extended. This then leads to the usage of build host include dirs, which are not available. Fix it by extending `UBOOT_MAKE_FLAGS` variable like it was done in commit 481339a04266 ("uboot-imx: fix wrong make flags overriding"). Fixes: 7094e6550336 ("uboot-imx: add support for TechNexion PICO-PI-IMX7D") Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'package/boot/uboot-imx')
-rw-r--r--package/boot/uboot-imx/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/boot/uboot-imx/Makefile b/package/boot/uboot-imx/Makefile
index c23e48732b..ade26db768 100644
--- a/package/boot/uboot-imx/Makefile
+++ b/package/boot/uboot-imx/Makefile
@@ -39,7 +39,7 @@ endef
define U-Boot/pico-pi-imx7d
NAME:=TechNexion PICO-PI-IMX7D
UBOOT_IMAGE:=SPL u-boot-dtb.img
- UBOOT_MAKE_FLAGS:=SPL u-boot-dtb.img
+ UBOOT_MAKE_FLAGS+=SPL u-boot-dtb.img
BUILD_SUBTARGET:=cortexa7
BUILD_DEVICES:=technexion_imx7d-pico-pi
endef