aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-imx6
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2018-08-26 13:47:23 +0200
committerFelix Fietkau <nbd@nbd.name>2018-09-03 12:06:24 +0200
commiteab7bcc8e1e321ecd43ec4af69207e7f53c53837 (patch)
tree2f44028f37ad9ea244187e1e99ff18ee10fcc441 /package/boot/uboot-imx6
parentb605a84a74170d2a07f53512cd57cd564db77249 (diff)
downloadupstream-eab7bcc8e1e321ecd43ec4af69207e7f53c53837.tar.gz
upstream-eab7bcc8e1e321ecd43ec4af69207e7f53c53837.tar.bz2
upstream-eab7bcc8e1e321ecd43ec4af69207e7f53c53837.zip
uboot-imx6: install images into STAGING_DIR_IMAGE
Will be used by a new combined image for cubox Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'package/boot/uboot-imx6')
-rw-r--r--package/boot/uboot-imx6/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/package/boot/uboot-imx6/Makefile b/package/boot/uboot-imx6/Makefile
index dd3a996736..6973cda5ae 100644
--- a/package/boot/uboot-imx6/Makefile
+++ b/package/boot/uboot-imx6/Makefile
@@ -72,4 +72,11 @@ UBOOT_TARGETS := \
UBOOT_MAKE_FLAGS += u-boot.imx
+define Build/InstallDev
+ $(INSTALL_DIR) $(STAGING_DIR_IMAGE)
+ $(foreach img,$(UBOOT_IMAGE), \
+ $(CP) $(PKG_BUILD_DIR)/$(img) $(STAGING_DIR_IMAGE)/$(BUILD_VARIANT)-$(img); \
+ )
+endef
+
$(eval $(call BuildPackage/U-Boot))