aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-imx6
diff options
context:
space:
mode:
authorVladimir Vid <vladimir.vid@sartura.hr>2018-07-09 11:09:53 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2018-08-25 15:40:23 +0200
commit6cda4f68619ec139be7897ea61b7f22c72c38b59 (patch)
tree76e77a670a9896c044be6e9689714a4fe66833d6 /package/boot/uboot-imx6
parent672c430d6e2a1dbc5f99fd5d8d9d47e6af02ad5e (diff)
downloadupstream-6cda4f68619ec139be7897ea61b7f22c72c38b59.tar.gz
upstream-6cda4f68619ec139be7897ea61b7f22c72c38b59.tar.bz2
upstream-6cda4f68619ec139be7897ea61b7f22c72c38b59.zip
imx6: Initial support for SolidRun CuBox-i devices based on i.MX6 processors (i1, i2, i2eX, and i4Pro).
- Specifications - CuBox i1: - SoC: i.MX6 Solo - Cores: 1 - Memory Size: 512MB - GPU: GC880 - Wifi/Bluetooth: Optional - USB 2.0 ports: 2 - Ethernet: 10/100/1000 Mbps CuBox i2 | i2eX: - SoC: i.MX6 Dual Lite - Cores: 2 - Memory Size: 1GB - GPU: GC2000 - Wifi/Bluetooth: Optional - USB 2.0 ports: 2 - Ethernet: 10/100/1000 Mbps CuBox i4Pro | i4x4: - SoC: i.MX6 Quad - Cores: 4 - Memory Size: 2/4 GB - GPU: GC2000 - Wifi/Bluetooth: Build In - USB 2.0 ports: 2 - Ethernet: 10/100/1000 Mbps Built-in u-boot requires SPL (secondary program loader) to be present on the SD-card regardless of the image type which will be loaded. SPL is generated by the u-boot-mx6cuboxi package which is preselected by the target device and can be found in bin/u-boot-mx6cuboxi directory. Flashing the SPL: dd if=/dev/zero of=/dev/mmcblk0 bs=1M count=4 dd if=bin/targets/imx6/generic/u-boot-mx6cuboxi/SPL of=/dev/mmcblk0 bs=1K seek=1 Preparing the firmware on the SD-card: (echo o; echo n; echo p; echo 1; echo ''; echo ''; echo w) | fdisk /dev/mmcblk0 mkfs.ext4 /dev/mmcblk0p1 mount /dev/mmcblk0p1 /mnt tar -xzf bin/targets/imx6/generic/openwrt-imx6-device-cubox-i-rootfs.tar.gz -C /mnt/ mkdir -p /mnt/boot cp bin/targets/imx6/generic/{*-uImage,*.dtb,*.scr} /mnt/boot/ Generated u-boot.img needs to be placed on the first partition: cp bin/targets/imx6/generic/u-boot-mx6cuboxi/u-boot.img /mnt/ To boot from the SD card: Boot script which sets mmc/dtb parameters and boots the board is automatically sourced. If this does not work for any reason: mmc dev 0; load mmc 0:1 $scriptaddr boot/boot.scr; source $scriptaddr Currently imx6dl-cubox-i.dtb (Dual Lite) and imx6q-cubox-i.dtb (Quad) device trees are available. Tested on i4Pro, MMC, USB (+ HiD), HDMI and ethernet ports are working. Wireless and bluetooth are broken ATM. According to SolidRun forums, BCM4329/BCM4330 firmware is used which works fine on older kernels. Signed-off-by: Vladimir Vid <vladimir.vid@sartura.hr>
Diffstat (limited to 'package/boot/uboot-imx6')
-rw-r--r--package/boot/uboot-imx6/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/package/boot/uboot-imx6/Makefile b/package/boot/uboot-imx6/Makefile
index 613a5338ef..dd3a996736 100644
--- a/package/boot/uboot-imx6/Makefile
+++ b/package/boot/uboot-imx6/Makefile
@@ -20,6 +20,12 @@ define U-Boot/Default
UBOOT_IMAGE:=u-boot.imx
endef
+define U-Boot/mx6cuboxi
+ NAME:=SolidRun Cubox-i boards
+ UBOOT_IMAGE:=SPL u-boot.img
+ UBOOT_MAKE_FLAGS:=SPL u-boot.img
+endef
+
define U-Boot/mx6sabresd
NAME:=SABRE i.MX6Quad board
endef
@@ -54,6 +60,7 @@ define U-Boot/wandboard
endef
UBOOT_TARGETS := \
+ mx6cuboxi \
mx6sabresd \
nitrogen6dl \
nitrogen6dl2g \