aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-envtools
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2013-07-02 23:08:19 +0000
committerLuka Perkov <luka@openwrt.org>2013-07-02 23:08:19 +0000
commitf6852707e464a6b894fb94c2ab36646ac0a8bedd (patch)
tree18d7bf1c2e9a5fc26ad6149bda60096f54779dea /package/boot/uboot-envtools
parent374758b6da704bcb229a7950a67e73fb824078b5 (diff)
downloadupstream-f6852707e464a6b894fb94c2ab36646ac0a8bedd.tar.gz
upstream-f6852707e464a6b894fb94c2ab36646ac0a8bedd.tar.bz2
upstream-f6852707e464a6b894fb94c2ab36646ac0a8bedd.zip
[package] uboot-envtools: add support for imx6 target
Signed-off-by: Luka Perkov <luka@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37136 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/boot/uboot-envtools')
-rw-r--r--package/boot/uboot-envtools/Makefile4
-rw-r--r--package/boot/uboot-envtools/files/imx624
2 files changed, 28 insertions, 0 deletions
diff --git a/package/boot/uboot-envtools/Makefile b/package/boot/uboot-envtools/Makefile
index f83b062a3b..3a3e95515c 100644
--- a/package/boot/uboot-envtools/Makefile
+++ b/package/boot/uboot-envtools/Makefile
@@ -61,6 +61,10 @@ ifneq ($(CONFIG_TARGET_cns3xxx),)
$(INSTALL_DIR) $(1)/etc/uci-defaults
$(INSTALL_BIN) ./files/cns3xxx $(1)/etc/uci-defaults/30_uboot-envtools
endif
+ifneq ($(CONFIG_TARGET_imx6),)
+ $(INSTALL_DIR) $(1)/etc/uci-defaults
+ $(INSTALL_BIN) ./files/imx6 $(1)/etc/uci-defaults/30_uboot-envtools
+endif
ifneq ($(CONFIG_TARGET_kirkwood),)
$(INSTALL_DIR) $(1)/etc/uci-defaults
$(INSTALL_BIN) ./files/kirkwood $(1)/etc/uci-defaults/30_uboot-envtools
diff --git a/package/boot/uboot-envtools/files/imx6 b/package/boot/uboot-envtools/files/imx6
new file mode 100644
index 0000000000..66fceac841
--- /dev/null
+++ b/package/boot/uboot-envtools/files/imx6
@@ -0,0 +1,24 @@
+#!/bin/sh
+#
+# Copyright (C) 2013 OpenWrt.org
+#
+
+[ -e /etc/config/ubootenv ] && exit 0
+
+touch /etc/config/ubootenv
+
+. /lib/uboot-envtools.sh
+. /lib/functions.sh
+
+board=$(cat /proc/device-tree/model)
+
+case "$board" in
+"Wandboard i.MX6 Dual Lite Board")
+ ubootenv_add_uci_config "/dev/mmcblk0" "0x60000" "0x2000" "0x2000"
+ ;;
+esac
+
+config_load ubootenv
+config_foreach ubootenv_add_app_config ubootenv
+
+exit 0