aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-envtools/Makefile
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke.mehrtens@intel.com>2019-11-07 21:01:40 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2019-11-09 20:42:04 +0100
commit0803b62fc617a140da094a97b1c8dc2b99a3a34f (patch)
tree2cfb6ec9b9e37f7ba0cfb36bb5f71f530b396a7c /package/boot/uboot-envtools/Makefile
parent963cee15e834816e4d6becfe51d3ea863ab66694 (diff)
downloadupstream-0803b62fc617a140da094a97b1c8dc2b99a3a34f.tar.gz
upstream-0803b62fc617a140da094a97b1c8dc2b99a3a34f.tar.bz2
upstream-0803b62fc617a140da094a97b1c8dc2b99a3a34f.zip
uboot-envtools: Add TARGET_LDFLAGS to fix PIE and RELRO
Forward the OpenWrt TARGET_LDFLAGS to the linker of the fw_printenv tool. In addition also use the more standard make invocation script. With this change the fw_printenv tool is built with PIE and Full RELRO support when activated globally in OpenWrt. Signed-off-by: Hauke Mehrtens <hauke.mehrtens@intel.com> (cherry picked from commit b7b2be0b268ced260ca8df84be1b0d469aaf6e38)
Diffstat (limited to 'package/boot/uboot-envtools/Makefile')
-rw-r--r--package/boot/uboot-envtools/Makefile15
1 files changed, 5 insertions, 10 deletions
diff --git a/package/boot/uboot-envtools/Makefile b/package/boot/uboot-envtools/Makefile
index 71b842b96e..15579e966b 100644
--- a/package/boot/uboot-envtools/Makefile
+++ b/package/boot/uboot-envtools/Makefile
@@ -51,16 +51,11 @@ define Build/Configure
touch $(PKG_BUILD_DIR)/include/generated/autoconf.h
endef
-TARGET_CFLAGS += -I$(STAGING_DIR)/usr/include
-
-define Build/Compile
- $(MAKE) -C $(PKG_BUILD_DIR) \
- CROSS_COMPILE="$(TARGET_CROSS)" \
- TARGET_CFLAGS="$(TARGET_CFLAGS)" \
- HOSTLDFLAGS= \
- no-dot-config-targets=envtools \
- envtools
-endef
+MAKE_FLAGS += \
+ TARGET_CFLAGS="$(TARGET_CFLAGS)" \
+ TARGET_LDFLAGS="$(TARGET_LDFLAGS)" \
+ no-dot-config-targets=envtools \
+ envtools
define Package/uboot-envtools/conffiles
/etc/config/ubootenv