aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-envtools/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2014-06-02 12:44:19 +0000
committerJohn Crispin <john@openwrt.org>2014-06-02 12:44:19 +0000
commitdab35f044ab30b29dd1777dc26d3334a81057662 (patch)
treecd014a0c2d937b60016aaa40e72a296f7e1a7e59 /package/boot/uboot-envtools/Makefile
parent85b8897d1a20b774ffeb7432e7efeb2ec97049e6 (diff)
downloadupstream-dab35f044ab30b29dd1777dc26d3334a81057662.tar.gz
upstream-dab35f044ab30b29dd1777dc26d3334a81057662.tar.bz2
upstream-dab35f044ab30b29dd1777dc26d3334a81057662.zip
uboot-envtools: add support for environment in ubi volume
On UBI enabled devices, U-Boot might store it's environment on UBI volume(s). Support this in uboot-envtools, so fw_setenv and fw_printenv can work on these platforms. Signed-off-by: Daniel Golle <daniel@makrotopia.org> SVN-Revision: 40929
Diffstat (limited to 'package/boot/uboot-envtools/Makefile')
-rw-r--r--package/boot/uboot-envtools/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/package/boot/uboot-envtools/Makefile b/package/boot/uboot-envtools/Makefile
index 9f167edbfb..dad971a4e4 100644
--- a/package/boot/uboot-envtools/Makefile
+++ b/package/boot/uboot-envtools/Makefile
@@ -21,6 +21,8 @@ PKG_MD5SUM:=6d2116d1385a66e9a59742caa9d62a54
PKG_BUILD_DIR:=$(BUILD_DIR)/u-boot-$(PKG_VERSION)
+PKG_BUILD_DEPENDS:=+fstools
+
include $(INCLUDE_DIR)/package.mk
define Package/uboot-envtools
@@ -34,15 +36,22 @@ define Package/uboot-envtools/description
This package includes tools to read and modify U-Boot bootloader environment.
endef
+define Package/uboot-envtools/config
+ source "$(SOURCE)/Config.in"
+endef
+
define Build/Configure
touch $(PKG_BUILD_DIR)/include/config.mk
touch $(PKG_BUILD_DIR)/include/config.h
endef
+TARGET_CFLAGS += -I$(STAGING_DIR)/usr/include
+
define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) \
CROSS_COMPILE="$(TARGET_CROSS)" \
TARGET_CFLAGS="$(TARGET_CFLAGS)" \
+ UBI="$(CONFIG_UBOOT_ENVTOOLS_UBI)" \
env
endef