aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-envtools/Makefile
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2013-07-02 23:08:17 +0000
committerLuka Perkov <luka@openwrt.org>2013-07-02 23:08:17 +0000
commitd352ff6cac7230b9279e011fe00e2ff482733576 (patch)
tree2ba233527d52e83426f0739e577ecdcaeaf303df /package/boot/uboot-envtools/Makefile
parent62cb88f5028f6bd1b88dfda636e1e912d635d763 (diff)
downloadupstream-d352ff6cac7230b9279e011fe00e2ff482733576.tar.gz
upstream-d352ff6cac7230b9279e011fe00e2ff482733576.tar.bz2
upstream-d352ff6cac7230b9279e011fe00e2ff482733576.zip
uboot-envtools: upgrade to 2013.07-rc1
Support for writing on MMC devices has been added. Signed-off-by: Luka Perkov <luka@openwrt.org> SVN-Revision: 37135
Diffstat (limited to 'package/boot/uboot-envtools/Makefile')
-rw-r--r--package/boot/uboot-envtools/Makefile20
1 files changed, 10 insertions, 10 deletions
diff --git a/package/boot/uboot-envtools/Makefile b/package/boot/uboot-envtools/Makefile
index 2d0f6b7986..f83b062a3b 100644
--- a/package/boot/uboot-envtools/Makefile
+++ b/package/boot/uboot-envtools/Makefile
@@ -9,12 +9,12 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=uboot-envtools
PKG_DISTNAME:=u-boot
-PKG_VERSION:=2013.04
+PKG_VERSION:=2013.07-rc1
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_DISTNAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=ftp://ftp.denx.de/pub/u-boot
-PKG_MD5SUM:=21bf962d69938ed4ed783b792b2b074e
+PKG_MD5SUM:=9b14d9a8981ce2e429956af7cc96996e
PKG_BUILD_DIR:=$(BUILD_DIR)/u-boot-$(PKG_VERSION)
@@ -55,23 +55,23 @@ define Package/uboot-envtools/install
$(INSTALL_DATA) ./files/uboot-envtools.sh $(1)/lib
ifneq ($(CONFIG_TARGET_ar71xx),)
$(INSTALL_DIR) $(1)/etc/uci-defaults
- $(INSTALL_BIN) ./files/ar71xx $(1)/etc/uci-defaults/uboot-envtools
+ $(INSTALL_BIN) ./files/ar71xx $(1)/etc/uci-defaults/30_uboot-envtools
+endif
+ifneq ($(CONFIG_TARGET_cns3xxx),)
+ $(INSTALL_DIR) $(1)/etc/uci-defaults
+ $(INSTALL_BIN) ./files/cns3xxx $(1)/etc/uci-defaults/30_uboot-envtools
endif
ifneq ($(CONFIG_TARGET_kirkwood),)
$(INSTALL_DIR) $(1)/etc/uci-defaults
- $(INSTALL_BIN) ./files/kirkwood $(1)/etc/uci-defaults/uboot-envtools
+ $(INSTALL_BIN) ./files/kirkwood $(1)/etc/uci-defaults/30_uboot-envtools
endif
ifneq ($(CONFIG_TARGET_lantiq),)
$(INSTALL_DIR) $(1)/etc/uci-defaults
- $(INSTALL_BIN) ./files/lantiq $(1)/etc/uci-defaults/uboot-envtools
+ $(INSTALL_BIN) ./files/lantiq $(1)/etc/uci-defaults/30_uboot-envtools
endif
ifneq ($(CONFIG_TARGET_ramips),)
$(INSTALL_DIR) $(1)/etc/uci-defaults
- $(INSTALL_BIN) ./files/ramips $(1)/etc/uci-defaults/uboot-envtools
-endif
-ifneq ($(CONFIG_TARGET_cns3xxx),)
- $(INSTALL_DIR) $(1)/etc/uci-defaults
- $(INSTALL_BIN) ./files/cns3xxx $(1)/etc/uci-defaults/uboot-envtools
+ $(INSTALL_BIN) ./files/ramips $(1)/etc/uci-defaults/30_uboot-envtools
endif
endef