aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-envtools/Makefile
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke.mehrtens@intel.com>2019-11-07 21:01:40 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2019-11-09 14:33:42 +0100
commitb7b2be0b268ced260ca8df84be1b0d469aaf6e38 (patch)
tree419aa3bfffa36f6dd2610e098bf875fbe2cc40f4 /package/boot/uboot-envtools/Makefile
parent39035df71c37d474be2cb2a0fad8d70da095c68b (diff)
downloadupstream-b7b2be0b268ced260ca8df84be1b0d469aaf6e38.tar.gz
upstream-b7b2be0b268ced260ca8df84be1b0d469aaf6e38.tar.bz2
upstream-b7b2be0b268ced260ca8df84be1b0d469aaf6e38.zip
uboot-envtools: Add TARGET_LDFLAGS to fix PIE and RELRO
Forward the OpenWrt TARGET_LDFLAGS to the linker of the fw_printenv tool. In addition also use the more standard make invocation script. With this change the fw_printenv tool is built with PIE and Full RELRO support when activated globally in OpenWrt. Signed-off-by: Hauke Mehrtens <hauke.mehrtens@intel.com>
Diffstat (limited to 'package/boot/uboot-envtools/Makefile')
-rw-r--r--package/boot/uboot-envtools/Makefile15
1 files changed, 5 insertions, 10 deletions
diff --git a/package/boot/uboot-envtools/Makefile b/package/boot/uboot-envtools/Makefile
index 4be043dcab..f880698e9c 100644
--- a/package/boot/uboot-envtools/Makefile
+++ b/package/boot/uboot-envtools/Makefile
@@ -51,16 +51,11 @@ define Build/Configure
touch $(PKG_BUILD_DIR)/include/generated/autoconf.h
endef
-TARGET_CFLAGS += -I$(STAGING_DIR)/usr/include
-
-define Build/Compile
- $(MAKE) -C $(PKG_BUILD_DIR) \
- CROSS_COMPILE="$(TARGET_CROSS)" \
- TARGET_CFLAGS="$(TARGET_CFLAGS)" \
- HOSTLDFLAGS= \
- no-dot-config-targets=envtools \
- envtools
-endef
+MAKE_FLAGS += \
+ TARGET_CFLAGS="$(TARGET_CFLAGS)" \
+ TARGET_LDFLAGS="$(TARGET_LDFLAGS)" \
+ no-dot-config-targets=envtools \
+ envtools
define Package/uboot-envtools/conffiles
/etc/config/ubootenv