aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-envtools/Makefile
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2013-04-11 16:04:31 +0000
committerLuka Perkov <luka@openwrt.org>2013-04-11 16:04:31 +0000
commitb591e15f362de31f9fba8905347451b3122cff8c (patch)
tree7df3648ba375fbb79b7dabaa89f3276ca8ca9fa9 /package/boot/uboot-envtools/Makefile
parent0d32469457cda703b8e0487c4ef0de6a36e86626 (diff)
downloadupstream-b591e15f362de31f9fba8905347451b3122cff8c.tar.gz
upstream-b591e15f362de31f9fba8905347451b3122cff8c.tar.bz2
upstream-b591e15f362de31f9fba8905347451b3122cff8c.zip
This adds Gateworks Laguna family board support. Note that some Laguna boards have SPI flash and others have NOR flash, thus the size/erasesize are detected dynamically.
Signed-off-by: Tim Harvey <tharvey@gateworks.com> SVN-Revision: 36313
Diffstat (limited to 'package/boot/uboot-envtools/Makefile')
-rw-r--r--package/boot/uboot-envtools/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/boot/uboot-envtools/Makefile b/package/boot/uboot-envtools/Makefile
index 55aaf885f1..ded9678be9 100644
--- a/package/boot/uboot-envtools/Makefile
+++ b/package/boot/uboot-envtools/Makefile
@@ -69,6 +69,10 @@ ifneq ($(CONFIG_TARGET_ramips),)
$(INSTALL_DIR) $(1)/etc/uci-defaults
$(INSTALL_BIN) ./files/ramips $(1)/etc/uci-defaults/uboot-envtools
endif
+ifneq ($(CONFIG_TARGET_cns3xxx),)
+ $(INSTALL_DIR) $(1)/etc/uci-defaults
+ $(INSTALL_BIN) ./files/cns3xxx $(1)/etc/uci-defaults/uboot-envtools
+endif
endef
$(eval $(call BuildPackage,uboot-envtools))