aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-envtools/Makefile
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2014-06-29 12:38:35 +0000
committerImre Kaloz <kaloz@openwrt.org>2014-06-29 12:38:35 +0000
commita91b9e35a4fb946c4f8490d2fb93e49a5814eb73 (patch)
tree0fc92b505c001bdf6a5eccaade181a46a8a2c7a8 /package/boot/uboot-envtools/Makefile
parent38f596d8f4859d5283dcbdeca8975f9f8d7dbbc6 (diff)
downloadupstream-a91b9e35a4fb946c4f8490d2fb93e49a5814eb73.tar.gz
upstream-a91b9e35a4fb946c4f8490d2fb93e49a5814eb73.tar.bz2
upstream-a91b9e35a4fb946c4f8490d2fb93e49a5814eb73.zip
add mvebu support
Signed-off-by: Imre Kaloz <kaloz@openwrt.org> SVN-Revision: 41380
Diffstat (limited to 'package/boot/uboot-envtools/Makefile')
-rw-r--r--package/boot/uboot-envtools/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/package/boot/uboot-envtools/Makefile b/package/boot/uboot-envtools/Makefile
index 301a0e432a..c6f1fbaff6 100644
--- a/package/boot/uboot-envtools/Makefile
+++ b/package/boot/uboot-envtools/Makefile
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=uboot-envtools
PKG_DISTNAME:=u-boot
PKG_VERSION:=2014.04
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_SOURCE:=$(PKG_DISTNAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:= \
@@ -86,6 +86,10 @@ ifneq ($(CONFIG_TARGET_lantiq),)
$(INSTALL_DIR) $(1)/etc/uci-defaults
$(INSTALL_DATA) ./files/lantiq $(1)/etc/uci-defaults/30_uboot-envtools
endif
+ifneq ($(CONFIG_TARGET_mvebu),)
+ $(INSTALL_DIR) $(1)/etc/uci-defaults
+ $(INSTALL_BIN) ./files/mvebu $(1)/etc/uci-defaults/30_uboot-envtools
+endif
ifneq ($(CONFIG_TARGET_mxs),)
$(INSTALL_DIR) $(1)/etc/uci-defaults
$(INSTALL_BIN) ./files/mxs $(1)/etc/uci-defaults/30_uboot-envtools