aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-envtools/Makefile
diff options
context:
space:
mode:
authorLuis Araneda <luaraneda@gmail.com>2018-04-06 11:23:34 -0300
committerHauke Mehrtens <hauke@hauke-m.de>2018-04-18 23:59:32 +0200
commit68150d3125447a40cf103aeefd9bcb6c874e6769 (patch)
treee2c78ddaccb31c4da0dc874a0d412f5332b63233 /package/boot/uboot-envtools/Makefile
parent7b758f7f4faceaea6b2d484658dfecd0e3ea3e23 (diff)
downloadupstream-68150d3125447a40cf103aeefd9bcb6c874e6769.tar.gz
upstream-68150d3125447a40cf103aeefd9bcb6c874e6769.tar.bz2
upstream-68150d3125447a40cf103aeefd9bcb6c874e6769.zip
uboot-envtools: update to 2018.03
Several changes has been made: + AES support has been removed by upstream commit c6831c7 (2017-11-14) [remove patch "200-fw_env_no_aes.patch"] + Support for UBI volumes has beed added by upstream commit 34255b9 (2017-11-15) [remove patch "300-support-env-in-ubivol-chardev.patch"] + A command line argument has beed added ("-c") to manually indicate the location of the environment configuration file Also, patch "400-u-boot-2015.10-stdint.patch" is no longer necessary, and the config option to enable UBI support has been removed. Size comparisons: fw_printenv size: Target Before After ar71xx 15,189 bytes 18,133 bytes (+2,944 bytes) ipq40xx 20,873 bytes 20,987 bytes (+114 bytes) mvebu 20,881 bytes 20,991 bytes (+110 bytes) ramips 15,128 bytes 18,072 bytes (+2,944 bytes) OPKG package size: Target Before After ar71xx 11,309 bytes 12,875 bytes (+1,566 bytes) ipq40xx 11,772 bytes 13,299 bytes (+1,527 bytes) mvebu 11,609 bytes 13,114 bytes (+1,505 bytes) ramips 10,975 bytes 12,503 bytes (+1,528 bytes) Compile tested: ipq40xx (musl, glibc, gcc5-musl), ar71xx, mvebu, ramips Run tested: ipq40xx (ASUS RT-AC58U) Signed-off-by: Luis Araneda <luaraneda@gmail.com>
Diffstat (limited to 'package/boot/uboot-envtools/Makefile')
-rw-r--r--package/boot/uboot-envtools/Makefile16
1 files changed, 6 insertions, 10 deletions
diff --git a/package/boot/uboot-envtools/Makefile b/package/boot/uboot-envtools/Makefile
index 442cf3fd83..c8eafbe664 100644
--- a/package/boot/uboot-envtools/Makefile
+++ b/package/boot/uboot-envtools/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=uboot-envtools
PKG_DISTNAME:=u-boot
-PKG_VERSION:=2015.10
+PKG_VERSION:=2018.03
PKG_RELEASE:=1
PKG_BUILD_DIR:=$(BUILD_DIR)/u-boot-$(PKG_VERSION)
@@ -17,7 +17,7 @@ PKG_SOURCE:=$(PKG_DISTNAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=\
http://mirror2.openwrt.org/sources \
ftp://ftp.denx.de/pub/u-boot
-PKG_HASH:=bdc68d5f9455ad933b059c735d983f2c8b6b552dafb062e5ff1444f623021955
+PKG_HASH:=7e7477534409d5368eb1371ffde6820f0f79780a1a1f676161c48442cb303dfd
PKG_BUILD_DEPENDS:=fstools
@@ -42,13 +42,10 @@ define Package/uboot-envtools/description
This package includes tools to read and modify U-Boot bootloader environment.
endef
-define Package/uboot-envtools/config
- source "$(SOURCE)/Config.in"
-endef
-
define Build/Configure
- touch $(PKG_BUILD_DIR)/include/config.mk
touch $(PKG_BUILD_DIR)/include/config.h
+ mkdir -p $(PKG_BUILD_DIR)/include/config
+ touch $(PKG_BUILD_DIR)/include/config/auto.conf
mkdir -p $(PKG_BUILD_DIR)/include/generated
touch $(PKG_BUILD_DIR)/include/generated/autoconf.h
endef
@@ -59,10 +56,9 @@ define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) \
CROSS_COMPILE="$(TARGET_CROSS)" \
TARGET_CFLAGS="$(TARGET_CFLAGS)" \
- UBI="$(CONFIG_UBOOT_ENVTOOLS_UBI)" \
- dot-config=0 \
HOSTLDFLAGS= \
- env
+ no-dot-config-targets=envtools \
+ envtools
endef
define Package/uboot-envtools/conffiles