aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-bcm4908/Makefile
diff options
context:
space:
mode:
authorRafał Miłecki <rafal@milecki.pl>2022-07-20 13:47:06 +0200
committerRafał Miłecki <rafal@milecki.pl>2022-07-28 00:50:13 +0200
commite0d3dc5de195d70f740178fe49b0928ca39ae58f (patch)
tree0004c29e1d7529b08ba34e587580121c678bf45a /package/boot/uboot-bcm4908/Makefile
parent066547b9742bb301981ec8941950399d3c7d8a6b (diff)
downloadupstream-e0d3dc5de195d70f740178fe49b0928ca39ae58f.tar.gz
upstream-e0d3dc5de195d70f740178fe49b0928ca39ae58f.tar.bz2
upstream-e0d3dc5de195d70f740178fe49b0928ca39ae58f.zip
uboot-bcm4908: include SoC in output files
This fixes problem of overwriting BCM4908 U-Boot and DTB files by BCM4912 ones. That bug didn't allow booting BCM4908 devices. Fixes: f4c2dab544ec2 ("uboot-bcm4908: add BCM4912 build") Signed-off-by: Rafał Miłecki <rafal@milecki.pl> (cherry picked from commit a8e1e30543239e85ff5dc220368164b66cf73fba)
Diffstat (limited to 'package/boot/uboot-bcm4908/Makefile')
-rw-r--r--package/boot/uboot-bcm4908/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/package/boot/uboot-bcm4908/Makefile b/package/boot/uboot-bcm4908/Makefile
index d6b689c9ce..7eacd23a02 100644
--- a/package/boot/uboot-bcm4908/Makefile
+++ b/package/boot/uboot-bcm4908/Makefile
@@ -23,11 +23,13 @@ endef
define U-Boot/bcm4908
NAME:=Broadcom's BCM4908
UBOOT_CONFIG:=bcm94908
+ SOC:=bcm4908
endef
define U-Boot/bcm4912
NAME:=Broadcom's BCM4912
UBOOT_CONFIG:=bcm94912
+ SOC:=bcm4912
endef
UBOOT_TARGETS := \
@@ -46,8 +48,8 @@ endef
define Build/InstallDev
$(INSTALL_DIR) $(STAGING_DIR_IMAGE)/u-boot
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/$(UBOOT_IMAGE) $(STAGING_DIR_IMAGE)/u-boot/
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/u-boot.dtb $(STAGING_DIR_IMAGE)/u-boot/
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/$(UBOOT_IMAGE) $(STAGING_DIR_IMAGE)/u-boot/u-boot-$(SOC).bin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/u-boot.dtb $(STAGING_DIR_IMAGE)/u-boot/u-boot-$(SOC).dtb
$(INSTALL_BIN) $(PKG_BUILD_DIR)/arch/arm/dts/*.dtb $(STAGING_DIR_IMAGE)/u-boot/
endef