aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-at91
diff options
context:
space:
mode:
authorSandeep Sheriker Mallikarjun <sandeepsheriker.mallikarjun@microchip.com>2017-09-13 11:51:19 -0700
committerJohn Crispin <john@phrozen.org>2017-09-20 09:01:16 +0200
commit71a93a22fdd52b363ec3ec8b59a68ceeb1c6beff (patch)
tree663bd063958d88f644c74f5e4dcf6e0302bb01fa /package/boot/uboot-at91
parent09bf44109043811eba45e2113307be23cb45ea8a (diff)
downloadupstream-71a93a22fdd52b363ec3ec8b59a68ceeb1c6beff.tar.gz
upstream-71a93a22fdd52b363ec3ec8b59a68ceeb1c6beff.tar.bz2
upstream-71a93a22fdd52b363ec3ec8b59a68ceeb1c6beff.zip
uboot-at91: move BUILD_SUBTARGET from U-Boot/Default to devices
currenlty U-Boot/Default supports only at91 legacy devices.To add sama5 support, moving BUILD_SUBTARGET from U-Boot/Default to target devices. Signed-off-by: Sandeep Sheriker Mallikarjun <sandeepsheriker.mallikarjun@microchip.com>
Diffstat (limited to 'package/boot/uboot-at91')
-rw-r--r--package/boot/uboot-at91/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/boot/uboot-at91/Makefile b/package/boot/uboot-at91/Makefile
index 6a806ff635..68e4ba498b 100644
--- a/package/boot/uboot-at91/Makefile
+++ b/package/boot/uboot-at91/Makefile
@@ -17,16 +17,17 @@ include $(INCLUDE_DIR)/package.mk
define U-Boot/Default
BUILD_TARGET:=at91
- BUILD_SUBTARGET:=legacy
UBOOT_IMAGE:=u-boot.bin boot.bin
endef
define U-Boot/at91sam9m10g45ek_nandflash
NAME:=AT91SAM9M10G45-EK board (NandFlash)
+ BUILD_SUBTARGET:=legacy
endef
define U-Boot/at91sam9x5ek_nandflash
NAME:=AT91SAM9X5-EK board (NandFlash)
+ BUILD_SUBTARGET:=legacy
endef
UBOOT_TARGETS := \