aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-ar71xx/patches/010-enet-ag71xx.patch
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2012-10-16 13:44:25 +0000
committerJohn Crispin <john@openwrt.org>2012-10-16 13:44:25 +0000
commite75106aa0d82a64122954b5990b50ec80d8e4040 (patch)
treebcc8ab60e849b3a0debb601b13c7f5356d9683e8 /package/boot/uboot-ar71xx/patches/010-enet-ag71xx.patch
parent254d851d8a9434e9c8a12a6ec96538ba13101600 (diff)
downloadupstream-e75106aa0d82a64122954b5990b50ec80d8e4040.tar.gz
upstream-e75106aa0d82a64122954b5990b50ec80d8e4040.tar.bz2
upstream-e75106aa0d82a64122954b5990b50ec80d8e4040.zip
move boot related packages to their own folder
SVN-Revision: 33781
Diffstat (limited to 'package/boot/uboot-ar71xx/patches/010-enet-ag71xx.patch')
-rw-r--r--package/boot/uboot-ar71xx/patches/010-enet-ag71xx.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/package/boot/uboot-ar71xx/patches/010-enet-ag71xx.patch b/package/boot/uboot-ar71xx/patches/010-enet-ag71xx.patch
new file mode 100644
index 0000000000..ee90e32c7a
--- /dev/null
+++ b/package/boot/uboot-ar71xx/patches/010-enet-ag71xx.patch
@@ -0,0 +1,22 @@
+diff -ur u-boot-2010.03/drivers/net/Makefile u-boot-nbg/drivers/net/Makefile
+--- u-boot-2010.03/drivers/net/Makefile 2010-03-31 23:54:39.000000000 +0200
++++ u-boot-nbg/drivers/net/Makefile 2010-04-19 23:30:01.000000000 +0200
+@@ -27,6 +27,7 @@
+
+ COBJS-$(CONFIG_DRIVER_3C589) += 3c589.o
+ COBJS-$(CONFIG_PPC4xx_EMAC) += 4xx_enet.o
++COBJS-$(CONFIG_AG71XX) += ag71xx.o
+ COBJS-$(CONFIG_DRIVER_AT91EMAC) += at91_emac.o
+ COBJS-$(CONFIG_DRIVER_AX88180) += ax88180.o
+ COBJS-$(CONFIG_BCM570x) += bcm570x.o bcm570x_autoneg.o 5701rls.o
+diff -ur u-boot-2010.03/include/netdev.h u-boot-nbg/include/netdev.h
+--- u-boot-2010.03/include/netdev.h 2010-03-31 23:54:39.000000000 +0200
++++ u-boot-nbg/include/netdev.h 2010-05-02 11:30:58.000000000 +0200
+@@ -42,6 +42,7 @@
+
+ /* Driver initialization prototypes */
+ int au1x00_enet_initialize(bd_t*);
++int ag71xx_register(bd_t * bis, char *phyname[], u16 phyid[], u16 phyfixed[]);
+ int at91emac_register(bd_t *bis, unsigned long iobase);
+ int bfin_EMAC_initialize(bd_t *bis);
+ int cs8900_initialize(u8 dev_num, int base_addr);