aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-ar71xx/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-01-23 08:23:55 +0100
committerFelix Fietkau <nbd@nbd.name>2017-01-24 16:21:24 +0100
commit83783f296a18e6e481f23b2019575e45c437db4e (patch)
tree75d072cd86d6bd875e332f6164c5124b7b28ea14 /package/boot/uboot-ar71xx/Makefile
parentb27241a1a1b70e6b84f76b2233283f7ec727c224 (diff)
downloadupstream-83783f296a18e6e481f23b2019575e45c437db4e.tar.gz
upstream-83783f296a18e6e481f23b2019575e45c437db4e.tar.bz2
upstream-83783f296a18e6e481f23b2019575e45c437db4e.zip
uboot-ar71xx: switch to using u-boot.mk
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'package/boot/uboot-ar71xx/Makefile')
-rw-r--r--package/boot/uboot-ar71xx/Makefile84
1 files changed, 10 insertions, 74 deletions
diff --git a/package/boot/uboot-ar71xx/Makefile b/package/boot/uboot-ar71xx/Makefile
index 70f96713e6..e0bc39fe94 100644
--- a/package/boot/uboot-ar71xx/Makefile
+++ b/package/boot/uboot-ar71xx/Makefile
@@ -6,90 +6,26 @@
#
include $(TOPDIR)/rules.mk
-include $(INCLUDE_DIR)/kernel.mk
-PKG_NAME:=u-boot
PKG_VERSION:=2010.03
PKG_RELEASE:=1
-PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_HASH:=902d1b2c15787df55186fae4033685fb0c5a5a12755a08383e97c4a3e255925b
-PKG_SOURCE_URL:= \
- http://mirror2.openwrt.org/sources \
- ftp://ftp.denx.de/pub/u-boot
-PKG_TARGETS:=bin
-
-PKG_LICENSE:=GPL-2.0 GPL-2.0+
-PKG_LICENSE_FILES:=Licenses/README
+include $(INCLUDE_DIR)/u-boot.mk
include $(INCLUDE_DIR)/package.mk
-define uboot/Default
- TITLE:=
- CONFIG:=
- IMAGE:=
-endef
-
-define uboot/nbg460n_550n_550nh
- TITLE:=U-boot for the NBG460N/550N/550NH routers
- DEFAULT:=y if (TARGET_ar71xx_generic_DEVICE_NBG_460N_550N_550NH || TARGET_DEVICE_ar71xx_generic_DEVICE_NBG_460N_550N_550NH || TARGET_ar71xx_generic_Default)
-endef
-
-UBOOTS:=nbg460n_550n_550nh
-
-define Package/uboot/template
-define Package/uboot-ar71xx-$(1)
- SECTION:=boot
- CATEGORY:=Boot Loaders
- TITLE:=$(2)
- DEPENDS:=@TARGET_ar71xx_generic
- URL:=http://www.denx.de/wiki/U-Boot
- VARIANT:=$(1)
-endef
-endef
-
-define BuildUbootPackage
- $(eval $(uboot/Default))
- $(eval $(uboot/$(1)))
- $(call Package/uboot/template,$(1),$(TITLE))
+define U-Boot/Default
+ BUILD_TARGET:=ar71xx
+ BUILD_SUBTARGET:=generic
endef
-
-ifdef BUILD_VARIANT
-$(eval $(call uboot/$(BUILD_VARIANT)))
-UBOOT_CONFIG:=$(if $(CONFIG),$(CONFIG),$(BUILD_VARIANT))
-UBOOT_IMAGE:=$(if $(IMAGE),$(IMAGE),openwrt-$(BOARD)-$(BUILD_VARIANT)-u-boot.bin)
-endif
-
-define Build/Prepare
- $(call Build/Prepare/Default)
- $(CP) ./files/* $(PKG_BUILD_DIR)
- find $(PKG_BUILD_DIR) -name .svn | $(XARGS) rm -rf
-endef
-
-define Build/Configure
- $(MAKE) -C $(PKG_BUILD_DIR) \
- $(UBOOT_CONFIG)_config
-endef
-
-define Build/Compile
- $(MAKE) -C $(PKG_BUILD_DIR) \
- CROSS_COMPILE=$(TARGET_CROSS)
-endef
-
-define Package/uboot/install/template
-define Package/uboot-ar71xx-$(1)/install
- $(INSTALL_DIR) $$(1)
- $(CP) $(PKG_BUILD_DIR)/u-boot.bin $(BIN_DIR)/$(2)
-endef
+define U-Boot/nbg460n_550n_550nh
+ TITLE:=NBG460N/550N/550NH routers
+ BUILD_DEVICES:=NBG_460N_550N_550NH
+ HIDDEN:=y
endef
-$(foreach u,$(UBOOTS), \
- $(eval $(call Package/uboot/install/template,$(u),openwrt-$(BOARD)-$(SUBTARGET)-$(u)-u-boot.bin)) \
-)
+UBOOT_TARGETS:=nbg460n_550n_550nh
-$(foreach u,$(UBOOTS), \
- $(eval $(call BuildUbootPackage,$(u))) \
- $(eval $(call BuildPackage,uboot-ar71xx-$(u))) \
-)
+$(eval $(call BuildPackage/U-Boot))