aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/tfa-layerscape
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2021-12-28 16:10:37 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2021-12-28 18:04:13 +0100
commitd0501dc7fc078fb9e91d5365474db9ed8200f9e0 (patch)
treeac489e636bf590a8e29872ac42b57ed934c213b7 /package/boot/tfa-layerscape
parent137a7607ecde0a8e85c1e58c40b0db89b268dd82 (diff)
downloadupstream-d0501dc7fc078fb9e91d5365474db9ed8200f9e0.tar.gz
upstream-d0501dc7fc078fb9e91d5365474db9ed8200f9e0.tar.bz2
upstream-d0501dc7fc078fb9e91d5365474db9ed8200f9e0.zip
tfa-layerscape: fix build on systems without openssl headers
The build fails when the openssl/sha.h header file is not installed on the host system. Fix this by setting the HOSTCCFLAGS variable to the OpenWrt HOST_CFLAGS variable, without setting this the include paths and other modifications in the host flags done by OpenWrt will be ignored by the build. This fixes the following build problem: gcc -c -D_GNU_SOURCE -D_XOPEN_SOURCE=700 -Wall -Werror -pedantic -std=c99 -O2 -I../../include/tools_share fiptool.c -o fiptool.o In file included from fiptool.h:16, from fiptool.c:19: fiptool_platform.h:19:11: fatal error: openssl/sha.h: No such file or directory 19 | # include <openssl/sha.h> | ^~~~~~~~~~~~~~~ Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'package/boot/tfa-layerscape')
-rw-r--r--package/boot/tfa-layerscape/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/boot/tfa-layerscape/Makefile b/package/boot/tfa-layerscape/Makefile
index 31a900412e..84ababf5e0 100644
--- a/package/boot/tfa-layerscape/Makefile
+++ b/package/boot/tfa-layerscape/Makefile
@@ -25,7 +25,8 @@ define Host/Compile
$(MAKE) -C \
$(HOST_BUILD_DIR)/tools/fiptool \
CFLAGS="$(HOST_CFLAGS)" \
- LDFLAGS="$(HOST_LDFLAGS)"
+ LDFLAGS="$(HOST_LDFLAGS)" \
+ HOSTCCFLAGS="$(HOST_CFLAGS)"
$(MAKE) -C \
$(HOST_BUILD_DIR)/tools/nxp \
CFLAGS="$(HOST_CFLAGS)"