aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/tfa-layerscape/patches
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2021-09-19 19:30:37 -0700
committerPaul Spooren <mail@aparcar.org>2021-09-21 21:39:01 -1000
commit50773c5c989dc921f9fc17bcc48d10293eaebe5a (patch)
tree5272832b780ad4588967dc53fd90624738003795 /package/boot/tfa-layerscape/patches
parent96c7164acd80d07655c2d8dbb3dc4ce556a65e46 (diff)
downloadupstream-50773c5c989dc921f9fc17bcc48d10293eaebe5a.tar.gz
upstream-50773c5c989dc921f9fc17bcc48d10293eaebe5a.tar.bz2
upstream-50773c5c989dc921f9fc17bcc48d10293eaebe5a.zip
tfp-layerscape: update to LSDK-20.12
Fixes compilation with GCC11. Kept PKG_VERSION as there's some bug that chops off the 12 at the end. Refreshed other patch. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'package/boot/tfa-layerscape/patches')
-rw-r--r--package/boot/tfa-layerscape/patches/003-plat-nxp-tools-fix-create_pbl-and-byte_swap-host-bui.patch7
-rw-r--r--package/boot/tfa-layerscape/patches/010-gcc11.patch20
2 files changed, 20 insertions, 7 deletions
diff --git a/package/boot/tfa-layerscape/patches/003-plat-nxp-tools-fix-create_pbl-and-byte_swap-host-bui.patch b/package/boot/tfa-layerscape/patches/003-plat-nxp-tools-fix-create_pbl-and-byte_swap-host-bui.patch
index ce4d9c48bf..2b19d53c71 100644
--- a/package/boot/tfa-layerscape/patches/003-plat-nxp-tools-fix-create_pbl-and-byte_swap-host-bui.patch
+++ b/package/boot/tfa-layerscape/patches/003-plat-nxp-tools-fix-create_pbl-and-byte_swap-host-bui.patch
@@ -11,8 +11,6 @@ Signed-off-by: Biwen Li <biwen.li@nxp.com>
plat/nxp/tools/pbl_ch3.mk | 5 -----
2 files changed, 8 deletions(-)
-diff --git a/plat/nxp/tools/pbl_ch2.mk b/plat/nxp/tools/pbl_ch2.mk
-index afa43520..ff624dd9 100644
--- a/plat/nxp/tools/pbl_ch2.mk
+++ b/plat/nxp/tools/pbl_ch2.mk
@@ -20,8 +20,6 @@ ifeq ($(RCW),"")
@@ -32,8 +30,6 @@ index afa43520..ff624dd9 100644
${CREATE_PBL} -r ${RCW} -i ${BUILD_PLAT}/bl2.bin -b ${BOOT_MODE} -c ${SOC_NUM} -d ${BL2_BASE} -e ${BL2_BASE} \
-o ${BUILD_PLAT}/bl2_${BOOT_MODE}.pbl ;
# Swapping of RCW is required for QSPi Chassis 2 devices
-diff --git a/plat/nxp/tools/pbl_ch3.mk b/plat/nxp/tools/pbl_ch3.mk
-index 944ae3bb..9aa8f635 100644
--- a/plat/nxp/tools/pbl_ch3.mk
+++ b/plat/nxp/tools/pbl_ch3.mk
@@ -27,9 +27,6 @@ else
@@ -55,6 +51,3 @@ index 944ae3bb..9aa8f635 100644
# Add Block Copy command and populate boot loc ptrfor bl2.bin to RCW
${CREATE_PBL} -r ${RCW} -i ${BUILD_PLAT}/bl2.bin -b ${BOOT_MODE} -c ${SOC_NUM} -d ${BL2_BASE} -e ${BL2_BASE} \
-o ${BUILD_PLAT}/bl2_${BOOT_MODE}.pbl -f ${BL2_SRC_OFFSET};
---
-2.17.1
-
diff --git a/package/boot/tfa-layerscape/patches/010-gcc11.patch b/package/boot/tfa-layerscape/patches/010-gcc11.patch
new file mode 100644
index 0000000000..1cdc21a493
--- /dev/null
+++ b/package/boot/tfa-layerscape/patches/010-gcc11.patch
@@ -0,0 +1,20 @@
+--- a/common/runtime_svc.c
++++ b/common/runtime_svc.c
+@@ -38,7 +38,7 @@ uintptr_t handle_runtime_svc(uint32_t smc_fid,
+ u_register_t x1, x2, x3, x4;
+ int index;
+ unsigned int idx;
+- const rt_svc_desc_t *rt_svc_descs;
++ rt_svc_desc_t *rt_svc_descs = NULL;
+
+ assert(handle);
+ idx = get_unique_oen_from_smc_fid(smc_fid);
+@@ -48,7 +48,7 @@ uintptr_t handle_runtime_svc(uint32_t smc_fid,
+ if (index < 0 || index >= (int)RT_SVC_DECS_NUM)
+ SMC_RET1(handle, SMC_UNK);
+
+- rt_svc_descs = (rt_svc_desc_t *) RT_SVC_DESCS_START;
++ memcpy(rt_svc_descs, (rt_svc_desc_t *)RT_SVC_DESCS_START, MAX_RT_SVCS);
+
+ get_smc_params_from_ctx(handle, x1, x2, x3, x4);
+