aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/tfa-layerscape/Makefile
diff options
context:
space:
mode:
authorChristian Lamparter <chunkeey@gmail.com>2023-05-20 21:43:39 +0200
committerChristian Lamparter <chunkeey@gmail.com>2023-05-20 23:20:48 +0200
commit857345496bf1d4870320e856ae75104e166d78d1 (patch)
tree8836f32da962fe14227e1d12987a964ac1096a70 /package/boot/tfa-layerscape/Makefile
parent3f9526957b15e48f3b651bfcca377a9a6e8e1416 (diff)
downloadupstream-857345496bf1d4870320e856ae75104e166d78d1.tar.gz
upstream-857345496bf1d4870320e856ae75104e166d78d1.tar.bz2
upstream-857345496bf1d4870320e856ae75104e166d78d1.zip
tfa-layerscape: fix fiptool's build
A missing '\' caused the remaining parameters not to be passed to make. This fixes the following error: | gcc -c [...] fiptool.c -o fiptool.o | In file included from fiptool.h:16, | from fiptool.c:19: |fiptool_platform.h:19:11: fatal error: openssl/sha.h: No such file or directory | 19 | # include <openssl/sha.h> | | ^~~~~~~~~~~~~~~ |compilation terminated. |make[3]: *** [Makefile:58: fiptool.o] Error 1 as the HOST_CFLAGS are no longer passed. then, HOST_CFLAGS is specified as a command argument, this is a specific problem of our built since appending these needs the override directive. Fixes: df28bfe03247 ("tfa-layerscape: Change to github and use the latest tag") Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'package/boot/tfa-layerscape/Makefile')
-rw-r--r--package/boot/tfa-layerscape/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/boot/tfa-layerscape/Makefile b/package/boot/tfa-layerscape/Makefile
index c1ef217f47..3509658869 100644
--- a/package/boot/tfa-layerscape/Makefile
+++ b/package/boot/tfa-layerscape/Makefile
@@ -25,7 +25,7 @@ HOST_CFLAGS += -Wall -Werror -pedantic -std=c99
define Host/Compile
$(MAKE) -C \
$(HOST_BUILD_DIR)/tools/fiptool \
- PLAT_FIPTOOL_HELPER_MK="$(HOST_BUILD_DIR)/tools/nxp/plat_fiptool/plat_fiptool.mk"
+ PLAT_FIPTOOL_HELPER_MK="$(HOST_BUILD_DIR)/tools/nxp/plat_fiptool/plat_fiptool.mk" \
CFLAGS="$(HOST_CFLAGS)" \
LDFLAGS="$(HOST_LDFLAGS)" \
HOSTCCFLAGS="$(HOST_CFLAGS)"