aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/tfa-layerscape/Makefile
diff options
context:
space:
mode:
authorMartin Schiller <ms@dev.tdt.de>2021-10-11 12:43:55 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2021-12-13 23:22:29 +0100
commit294140c1247d42746e655a9bbaafcf4d1a9748a5 (patch)
tree3ee2810cb4ac9f3feb135ab78949cd71d3286182 /package/boot/tfa-layerscape/Makefile
parent674af9c1f6a811fdf1f1a82dc16ce19175a6e6d2 (diff)
downloadupstream-294140c1247d42746e655a9bbaafcf4d1a9748a5.tar.gz
upstream-294140c1247d42746e655a9bbaafcf4d1a9748a5.tar.bz2
upstream-294140c1247d42746e655a9bbaafcf4d1a9748a5.zip
tfa-layerscape: bump to LSDK-21.08
Update tfa package to latest LSDK-21.08. Signed-off-by: Martin Schiller <ms@dev.tdt.de>
Diffstat (limited to 'package/boot/tfa-layerscape/Makefile')
-rw-r--r--package/boot/tfa-layerscape/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/package/boot/tfa-layerscape/Makefile b/package/boot/tfa-layerscape/Makefile
index 6f0e175885..31a900412e 100644
--- a/package/boot/tfa-layerscape/Makefile
+++ b/package/boot/tfa-layerscape/Makefile
@@ -8,13 +8,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=tfa-layerscape
-PKG_VERSION:=LSDK-20.12
+PKG_VERSION:=LSDK-21.08
PKG_RELEASE:=$(AUTORELEASE)
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://source.codeaurora.org/external/qoriq/qoriq-components/atf
-PKG_SOURCE_VERSION:=LSDK-20.12
-PKG_MIRROR_HASH:=8e3a0bd33c00657beeb2df88a881b1831aeb790751cacd4c4fdf33ffa01e956e
+PKG_SOURCE_VERSION:=LSDK-21.08
+PKG_MIRROR_HASH:=500da1f5743255b2c301b89fba4df31d05a7dfbc731fbf137a88caf86f5568d0
PKG_BUILD_DEPENDS:=tfa-layerscape/host
include $(INCLUDE_DIR)/host-build.mk
@@ -27,14 +27,14 @@ define Host/Compile
CFLAGS="$(HOST_CFLAGS)" \
LDFLAGS="$(HOST_LDFLAGS)"
$(MAKE) -C \
- $(HOST_BUILD_DIR)/plat/nxp/tools \
+ $(HOST_BUILD_DIR)/tools/nxp \
CFLAGS="$(HOST_CFLAGS)"
endef
define Host/Install
$(INSTALL_BIN) $(HOST_BUILD_DIR)/tools/fiptool/fiptool $(STAGING_DIR_HOST)/bin/fiptool-layerscape
- $(INSTALL_BIN) $(HOST_BUILD_DIR)/plat/nxp/tools/create_pbl $(STAGING_DIR_HOST)/bin/tfa-create-pbl
- $(INSTALL_BIN) $(HOST_BUILD_DIR)/plat/nxp/tools/byte_swap $(STAGING_DIR_HOST)/bin/tfa-byte-swap
+ $(INSTALL_BIN) $(HOST_BUILD_DIR)/tools/nxp/create_pbl $(STAGING_DIR_HOST)/bin/tfa-create-pbl
+ $(INSTALL_BIN) $(HOST_BUILD_DIR)/tools/nxp/byte_swap $(STAGING_DIR_HOST)/bin/tfa-byte-swap
endef
define Package/tfa-generic