aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/rbcfg/Makefile
diff options
context:
space:
mode:
authorThibaut VARÈNE <hacks@slashdirt.org>2020-05-21 17:20:55 +0200
committerKoen Vandeputte <koen.vandeputte@ncentric.com>2020-05-28 11:09:10 +0200
commitf10da7cb4d44dde346bef73ff4500d91c5730767 (patch)
tree763ad6f1cbd70b640846f80a05b936621900e3dc /package/boot/rbcfg/Makefile
parent48b14b9cbe521580e9d3f75a5ee1eabdd0440de8 (diff)
downloadupstream-f10da7cb4d44dde346bef73ff4500d91c5730767.tar.gz
upstream-f10da7cb4d44dde346bef73ff4500d91c5730767.tar.bz2
upstream-f10da7cb4d44dde346bef73ff4500d91c5730767.zip
packages/boot: remove rbcfg
The new sysfs soft_config driver makes buggy rbcfg obsolete and entirely replaces it. Signed-off-by: Thibaut VARÈNE <hacks@slashdirt.org>
Diffstat (limited to 'package/boot/rbcfg/Makefile')
-rw-r--r--package/boot/rbcfg/Makefile47
1 files changed, 0 insertions, 47 deletions
diff --git a/package/boot/rbcfg/Makefile b/package/boot/rbcfg/Makefile
deleted file mode 100644
index 874ef06924..0000000000
--- a/package/boot/rbcfg/Makefile
+++ /dev/null
@@ -1,47 +0,0 @@
-#
-# Copyright (C) 2010 Gabor Juhos <juhosg@openwrt.org>
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=rbcfg
-PKG_RELEASE:=3
-
-PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
-
-PKG_FLAGS:=nonshared
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/rbcfg
- SECTION:=utils
- CATEGORY:=Utilities
- SUBMENU:=Boot Loaders
- TITLE:=RouterBOOT configuration tool
- DEPENDS:=@(TARGET_ar71xx||TARGET_ath79)
-endef
-
-define Package/rbcfg/description
- This package contains an utility to manipulate RouterBOOT configuration on the
- MikroTIK RB-4XX devices.
-endef
-
-define Build/Configure
-endef
-
-define Build/Compile
- $(MAKE) -C $(PKG_BUILD_DIR) \
- CC="$(TARGET_CC)" \
- CFLAGS="$(TARGET_CFLAGS) -Wall" \
- LDFLAGS="$(TARGET_LDFLAGS)"
-endef
-
-define Package/rbcfg/install
- $(INSTALL_DIR) $(1)/usr/sbin
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/rbcfg $(1)/usr/sbin/
-endef
-
-$(eval $(call BuildPackage,rbcfg))