aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/rbcfg/Makefile
diff options
context:
space:
mode:
authorThibaut VARENE <hacks@slashdirt.org>2017-02-25 17:34:50 +0100
committerJo-Philipp Wich <jo@mein.io>2017-10-07 15:00:26 +0200
commit2be307c99852dc859730b531e9b1cc2f9776234b (patch)
treec2fbee06ed0f16b80f6c74580836b24cd2c52948 /package/boot/rbcfg/Makefile
parentb9c31c44d719c7749c058aaa13b9c1503e9968f0 (diff)
downloadupstream-2be307c99852dc859730b531e9b1cc2f9776234b.tar.gz
upstream-2be307c99852dc859730b531e9b1cc2f9776234b.tar.bz2
upstream-2be307c99852dc859730b531e9b1cc2f9776234b.zip
rbcfg: Implement CPU frequency control
This patch implements CPU frequency control as found on several routerboard devices. Supported SoCs: - QCA953X - AR9344 Tested on hAP lite and mAP lite (QCA953x): steps of 50MHz Tested on LHG 5 (AR9344): steps of 50MHz On unsupported hardware, this patch is a NOP: it will not alter the new field. "rbcfg help" will display an empty "cpu_freq" help listing. "rbcfg show" will not show the cpu_freq field. "rbcfg set/get cpu_freq" will return an error code. Signed-off-by: Thibaut VARENE <hacks@slashdirt.org> [adjusted subject] Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'package/boot/rbcfg/Makefile')
-rw-r--r--package/boot/rbcfg/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/boot/rbcfg/Makefile b/package/boot/rbcfg/Makefile
index 412f7ab11a..9d9b97524a 100644
--- a/package/boot/rbcfg/Makefile
+++ b/package/boot/rbcfg/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=rbcfg
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)