aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/kobs-ng/Makefile
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2014-04-19 21:39:09 +0000
committerLuka Perkov <luka@openwrt.org>2014-04-19 21:39:09 +0000
commit350dd0f9acb0ed1c084ef197be31e4c8d2ea1935 (patch)
treeffce0389cb50759591e3066badf4bce979cf0cae /package/boot/kobs-ng/Makefile
parentb58e65f2ee1a95865874a7f5b637d460e372b1fe (diff)
downloadupstream-350dd0f9acb0ed1c084ef197be31e4c8d2ea1935.tar.gz
upstream-350dd0f9acb0ed1c084ef197be31e4c8d2ea1935.tar.bz2
upstream-350dd0f9acb0ed1c084ef197be31e4c8d2ea1935.zip
kobs-ng: Add support for overriding size
By default kobs-ng will use the size of /dev/mtd0 for the IMX bootstreams. This patch allows overriding that size in order to reserve space at the end of the mtd partition for u-boot.img in the case of using an SPL bootloader. For example, to flash an SPL bootloader that loads u-boot.img from 0xe0000 (14MB) offset in a 16MB /dev/mtd0: kobs-ng init -v -x --search_exponent=1 --chip_0_size=0xe00000 SPL nandwrite --start=0xe00000 --pad /dev/mtd0 u-boot.img Signed-off-by: Tim Harvey <tharvey@gateworks.com> SVN-Revision: 40532
Diffstat (limited to 'package/boot/kobs-ng/Makefile')
-rw-r--r--package/boot/kobs-ng/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/boot/kobs-ng/Makefile b/package/boot/kobs-ng/Makefile
index 1554e6835d..c43fa19243 100644
--- a/package/boot/kobs-ng/Makefile
+++ b/package/boot/kobs-ng/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2013 OpenWrt.org
+# Copyright (C) 2013-2014 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=kobs-ng
PKG_VERSION:=3.0.35-4.0.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://repository.timesys.com/buildsources/k/kobs-ng/kobs-ng-$(PKG_VERSION)/