aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/kobs-ng/Makefile
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2013-09-03 23:22:16 +0000
committerLuka Perkov <luka@openwrt.org>2013-09-03 23:22:16 +0000
commit1eb21b87bdd67b13b426fe5d19113dca6daee9b3 (patch)
treebf9636559622efab1cbfcb104f01e6ac45b8e7b6 /package/boot/kobs-ng/Makefile
parente01fb70f1bd277c9e05046579e43edef325dffa8 (diff)
downloadupstream-1eb21b87bdd67b13b426fe5d19113dca6daee9b3.tar.gz
upstream-1eb21b87bdd67b13b426fe5d19113dca6daee9b3.tar.bz2
upstream-1eb21b87bdd67b13b426fe5d19113dca6daee9b3.zip
kobs-ng: add new package
Signed-off-by: Tim Harvey <tharvey@gateworks.com> Signed-off-by: Luka Perkov <luka@openwrt.org> SVN-Revision: 37894
Diffstat (limited to 'package/boot/kobs-ng/Makefile')
-rw-r--r--package/boot/kobs-ng/Makefile45
1 files changed, 45 insertions, 0 deletions
diff --git a/package/boot/kobs-ng/Makefile b/package/boot/kobs-ng/Makefile
new file mode 100644
index 0000000000..1554e6835d
--- /dev/null
+++ b/package/boot/kobs-ng/Makefile
@@ -0,0 +1,45 @@
+#
+# Copyright (C) 2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=kobs-ng
+PKG_VERSION:=3.0.35-4.0.0
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://repository.timesys.com/buildsources/k/kobs-ng/kobs-ng-$(PKG_VERSION)/
+PKG_MD5SUM:=26104c577f59a6b81782a5bd16aadd82
+
+PKG_LICENSE:=GPLv2
+PKG_LICENSE_FILES:=COPYING
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/kobs-ng
+ SECTION:=utils
+ CATEGORY:=Utilities
+ TITLE:=Application for writing bootstreams to NAND flash
+ DEPENDS:=@TARGET_imx6
+endef
+
+define Package/kobs-ng/description
+ The kobs-ng application writes a bootstream to NAND flash with the proper
+ FCB/DBBT headers and replicated streams.
+endef
+
+define Build/Prepare
+ $(call Build/Prepare/Default)
+ echo "const char* git_sha = \"$(PKG_VERSION)\";" > $(PKG_BUILD_DIR)/autoversion.h
+endef
+
+define Package/kobs-ng/install
+ $(INSTALL_DIR) $(1)/usr/sbin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/kobs-ng $(1)/usr/sbin/
+endef
+
+$(eval $(call BuildPackage,kobs-ng))