aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/kexec-tools
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2019-06-15 14:57:14 +0200
committerJo-Philipp Wich <jo@mein.io>2019-06-20 14:16:08 +0200
commit74739c4228f3bd0aa757165c67c53016c3deb544 (patch)
tree6dc6ff0bb582a52f743f1da5dd0140a8d7e063f1 /package/boot/kexec-tools
parent75dcaf3d23301da35eb4a6d0efc5ba5a0ed09850 (diff)
downloadupstream-74739c4228f3bd0aa757165c67c53016c3deb544.tar.gz
upstream-74739c4228f3bd0aa757165c67c53016c3deb544.tar.bz2
upstream-74739c4228f3bd0aa757165c67c53016c3deb544.zip
treewide: fix syntax errors exposed after kconfig update
After commit e82a4d9cfb ("config: regenerate *_shipped sources") the mconf parser became more strict as a side effect and started to spew a series of warnings when evaluating our generated kconfig sources: tmp/.config-package.in:705:warning: ignoring unsupported character '@' The root cause of these warnings is a wrong use of the @SYMBOL dependency syntax in various Makefile. Fix the corresponding Makefiles by turning `@SYM||@SYM2` expressions into the proper `@(SYM||SYM2)` form. Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'package/boot/kexec-tools')
-rw-r--r--package/boot/kexec-tools/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/boot/kexec-tools/Makefile b/package/boot/kexec-tools/Makefile
index 76ea46f10f..ca41839869 100644
--- a/package/boot/kexec-tools/Makefile
+++ b/package/boot/kexec-tools/Makefile
@@ -44,7 +44,7 @@ define Package/kexec
$(call Package/kexec-tools/Default)
TITLE:=Kernel boots kernel
DEPENDS:=\
- @armeb||@arm||@i386||@x86_64||@powerpc64||@mipsel||@mips \
+ @(armeb||arm||i386||x86_64||powerpc64||mipsel||mips) \
+KEXEC_ZLIB:zlib +KEXEC_LZMA:liblzma @KERNEL_KEXEC
endef
@@ -55,7 +55,7 @@ endef
define Package/kdump
$(call Package/kexec-tools/Default)
TITLE:=Kernel crash analysis
- DEPENDS:=+kexec @i386||@x86_64||@arm @KERNEL_CRASH_DUMP
+ DEPENDS:=+kexec @(i386||x86_64||arm) @KERNEL_CRASH_DUMP
endef
define Package/kdump/description