aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/kexec-tools
diff options
context:
space:
mode:
authorPhilip Prindeville <philipp@redfish-solutions.com>2017-09-16 10:16:29 -0600
committerJohn Crispin <john@phrozen.org>2018-02-11 16:05:48 +0100
commitd59cc79e00e74184d42aec8743d57441c6b734bc (patch)
treeb970c0bfd47ddb19b2532afab57850fb79aa1e53 /package/boot/kexec-tools
parent14951e8f8e09ba6e2cff140769189a66155a5345 (diff)
downloadupstream-d59cc79e00e74184d42aec8743d57441c6b734bc.tar.gz
upstream-d59cc79e00e74184d42aec8743d57441c6b734bc.tar.bz2
upstream-d59cc79e00e74184d42aec8743d57441c6b734bc.zip
kexec-tools: issue warning when dd'ing vmcore
With no warning, it just looks like the box has hung during boot. We don't want users resetting it without having captured a crashdump. Signed-off-by: Philip Prindeville <philipp@redfish-solutions.com>
Diffstat (limited to 'package/boot/kexec-tools')
-rw-r--r--package/boot/kexec-tools/Makefile2
-rwxr-xr-xpackage/boot/kexec-tools/files/kdump.init2
2 files changed, 3 insertions, 1 deletions
diff --git a/package/boot/kexec-tools/Makefile b/package/boot/kexec-tools/Makefile
index 1c686a2540..71a10b22f9 100644
--- a/package/boot/kexec-tools/Makefile
+++ b/package/boot/kexec-tools/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=kexec-tools
PKG_VERSION:=2.0.14
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@KERNEL/linux/utils/kernel/kexec
diff --git a/package/boot/kexec-tools/files/kdump.init b/package/boot/kexec-tools/files/kdump.init
index 057b8cc17a..6a6a94c07e 100755
--- a/package/boot/kexec-tools/files/kdump.init
+++ b/package/boot/kexec-tools/files/kdump.init
@@ -43,8 +43,10 @@ run_kdump() {
timestamp=$(date "+%Y%m%dT%H%M%S")
if [ "$save_vmcore" -eq 1 ]; then
+ echo -n "Saving vmcore (this may take a while)..."
# would like 'sparse' but busybox doesn't support it
dd if=/proc/vmcore of="$path/vmcore-$timestamp" conv=fsync bs=1M
+ echo " done"
fi
if [ "$save_dmesg" -eq 1 ]; then