aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/kexec-tools/patches/0005-mips-fix-warning-about-implicit-type-conversion.patch
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-02-13 07:42:13 +0000
committerJohn Crispin <john@openwrt.org>2015-02-13 07:42:13 +0000
commitcd96421b19a4c9dd058cee724cc5b4fe5f0d74db (patch)
tree13507db4b81aeaf396a52aa6a709627c312dee08 /package/boot/kexec-tools/patches/0005-mips-fix-warning-about-implicit-type-conversion.patch
parent15cc0550c78b71c50f1b3a04d2fce68e8425456a (diff)
downloadupstream-cd96421b19a4c9dd058cee724cc5b4fe5f0d74db.tar.gz
upstream-cd96421b19a4c9dd058cee724cc5b4fe5f0d74db.tar.bz2
upstream-cd96421b19a4c9dd058cee724cc5b4fe5f0d74db.zip
kexec-tools: bump version from v2.0.4 to v2.0.9.
- kexec-tools is now distributed with tarballs of .tar.gz and .tar.xz format; .tar.bz2 are not provided anymore. - Add CONFIG_KEXEC_LZMA for selecting lzma support. Patches are updated along to: - Remove the now unnecessary patch 0004-mips_regdefs.patch. - Drop 100-reduce_size.patch because the size reduction is marginal. - Allow zlib and lzma support coexist together. This patch has been merged into upstream project. - Fix kexec-tools' configure.ac. - Fix a few compilation warnings. Size comparison of stripped binaries of kexec malta target with both zlib and lzma support enabled. - Before: 41447 - After: 42583 Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com> SVN-Revision: 44437
Diffstat (limited to 'package/boot/kexec-tools/patches/0005-mips-fix-warning-about-implicit-type-conversion.patch')
-rw-r--r--package/boot/kexec-tools/patches/0005-mips-fix-warning-about-implicit-type-conversion.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/package/boot/kexec-tools/patches/0005-mips-fix-warning-about-implicit-type-conversion.patch b/package/boot/kexec-tools/patches/0005-mips-fix-warning-about-implicit-type-conversion.patch
new file mode 100644
index 0000000000..008a62dcfd
--- /dev/null
+++ b/package/boot/kexec-tools/patches/0005-mips-fix-warning-about-implicit-type-conversion.patch
@@ -0,0 +1,30 @@
+From 00e75179b3b4b80e6e58d29a2bd948f97682fd00 Mon Sep 17 00:00:00 2001
+From: Yousong Zhou <yszhou4tech@gmail.com>
+Date: Mon, 9 Feb 2015 20:28:14 +0800
+Subject: [PATCH 5/5] mips: fix warning about implicit type conversion.
+
+Fixes the following warning.
+
+ kexec/arch/mips/kexec-elf-mips.c:161:16: warning: assignment makes integer from pointer without a cast [enabled by default]
+
+Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
+---
+ kexec/arch/mips/kexec-elf-mips.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/kexec/arch/mips/kexec-elf-mips.c b/kexec/arch/mips/kexec-elf-mips.c
+index a27d986..8a6419a 100644
+--- a/kexec/arch/mips/kexec-elf-mips.c
++++ b/kexec/arch/mips/kexec-elf-mips.c
+@@ -158,7 +158,7 @@ int elf_mips_load(int argc, char **argv, const char *buf, off_t len,
+ if (info->kexec_flags & KEXEC_ON_CRASH)
+ /* In case of crashdump segment[0] is kernel.
+ * Put cmdline just after it. */
+- cmdline_addr = info->segment[0].mem +
++ cmdline_addr = (unsigned long)info->segment[0].mem +
+ info->segment[0].memsz;
+ else
+ cmdline_addr = 0;
+--
+1.7.10.4
+