aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/kexec-tools/patches/0004-mips-remove-unused-variable.patch
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-02-13 07:42:13 +0000
committerJohn Crispin <john@openwrt.org>2015-02-13 07:42:13 +0000
commitcd96421b19a4c9dd058cee724cc5b4fe5f0d74db (patch)
tree13507db4b81aeaf396a52aa6a709627c312dee08 /package/boot/kexec-tools/patches/0004-mips-remove-unused-variable.patch
parent15cc0550c78b71c50f1b3a04d2fce68e8425456a (diff)
downloadupstream-cd96421b19a4c9dd058cee724cc5b4fe5f0d74db.tar.gz
upstream-cd96421b19a4c9dd058cee724cc5b4fe5f0d74db.tar.bz2
upstream-cd96421b19a4c9dd058cee724cc5b4fe5f0d74db.zip
kexec-tools: bump version from v2.0.4 to v2.0.9.
- kexec-tools is now distributed with tarballs of .tar.gz and .tar.xz format; .tar.bz2 are not provided anymore. - Add CONFIG_KEXEC_LZMA for selecting lzma support. Patches are updated along to: - Remove the now unnecessary patch 0004-mips_regdefs.patch. - Drop 100-reduce_size.patch because the size reduction is marginal. - Allow zlib and lzma support coexist together. This patch has been merged into upstream project. - Fix kexec-tools' configure.ac. - Fix a few compilation warnings. Size comparison of stripped binaries of kexec malta target with both zlib and lzma support enabled. - Before: 41447 - After: 42583 Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com> SVN-Revision: 44437
Diffstat (limited to 'package/boot/kexec-tools/patches/0004-mips-remove-unused-variable.patch')
-rw-r--r--package/boot/kexec-tools/patches/0004-mips-remove-unused-variable.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/package/boot/kexec-tools/patches/0004-mips-remove-unused-variable.patch b/package/boot/kexec-tools/patches/0004-mips-remove-unused-variable.patch
new file mode 100644
index 0000000000..8626c41347
--- /dev/null
+++ b/package/boot/kexec-tools/patches/0004-mips-remove-unused-variable.patch
@@ -0,0 +1,30 @@
+From 904e9ae892b0592c916a013869e3be3d830e0155 Mon Sep 17 00:00:00 2001
+From: Yousong Zhou <yszhou4tech@gmail.com>
+Date: Mon, 9 Feb 2015 20:11:04 +0800
+Subject: [PATCH 4/5] mips: remove unused variable.
+
+Fixes the following compilation warning.
+
+ kexec/arch/mips/crashdump-mips.c:151:6: warning: unused variable 'i' [-Wunused-variable]
+
+Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
+---
+ kexec/arch/mips/crashdump-mips.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/kexec/arch/mips/crashdump-mips.c b/kexec/arch/mips/crashdump-mips.c
+index 98c9f7c..dc68cb4 100644
+--- a/kexec/arch/mips/crashdump-mips.c
++++ b/kexec/arch/mips/crashdump-mips.c
+@@ -148,7 +148,7 @@ static int exclude_crash_reserve_region(int *nr_ranges)
+ static int get_crash_memory_ranges(struct memory_range **range, int *ranges)
+ {
+ const char iomem[] = "/proc/iomem";
+- int i, memory_ranges = 0;
++ int memory_ranges = 0;
+ char line[MAX_LINE];
+ FILE *fp;
+ unsigned long long start, end;
+--
+1.7.10.4
+