aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/kexec-tools/Makefile
diff options
context:
space:
mode:
authorAndre Heider <a.heider@gmail.com>2023-02-02 21:16:21 +0100
committerChristian Marangi <ansuelsmth@gmail.com>2023-03-21 18:28:22 +0100
commitda3700988d9e34e380bae21ee23d5458a7e972b4 (patch)
tree20d82e514ac77f4f0de8deb7f1274a8f409646df /package/boot/kexec-tools/Makefile
parent5c545bdb365a78b8995ddfa441a6018f7ff3c011 (diff)
downloadupstream-da3700988d9e34e380bae21ee23d5458a7e972b4.tar.gz
upstream-da3700988d9e34e380bae21ee23d5458a7e972b4.tar.bz2
upstream-da3700988d9e34e380bae21ee23d5458a7e972b4.zip
treewide: add support for "gc-sections" in PKG_BUILD_FLAGS
This reduces open coding and allows to easily add a knob to enable it treewide, where chosen packages can still opt-out via "no-gc-sections". Note: libnl, mbedtls and opkg only used the CFLAGS part without the LDFLAGS counterpart. That doesn't help at all if the goal is to produce smaller binaries. I consider that an accident, and this fixes it. Note: there are also packages using only the LDFLAGS part. I didn't touch those, as gc might have been disabled via CFLAGS intentionally. Signed-off-by: Andre Heider <a.heider@gmail.com>
Diffstat (limited to 'package/boot/kexec-tools/Makefile')
-rw-r--r--package/boot/kexec-tools/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/package/boot/kexec-tools/Makefile b/package/boot/kexec-tools/Makefile
index 0cb7688a24..7f06ec7d64 100644
--- a/package/boot/kexec-tools/Makefile
+++ b/package/boot/kexec-tools/Makefile
@@ -17,6 +17,8 @@ PKG_HASH:=7fe36a064101cd5c515e41b2be393dce3ca88adce59d6ee668e0af7c0c4570cd
PKG_CONFIG_DEPENDS := CONFIG_KEXEC_ZLIB CONFIG_KEXEC_LZMA
+PKG_BUILD_FLAGS:=gc-sections
+
include $(INCLUDE_DIR)/package.mk
define Package/kexec-tools/Default
@@ -82,9 +84,6 @@ CONFIGURE_ARGS = \
$(if $(CONFIG_KEXEC_LZMA),--with,--without)-lzma \
TARGET_LD="$(TARGET_CROSS)ld"
-TARGET_CFLAGS += -ffunction-sections -fdata-sections
-TARGET_LDFLAGS += -Wl,--gc-sections
-
CONFIGURE_VARS += \
BUILD_CC="$(HOSTCC)" \
TARGET_CC="$(TARGET_CC)"