aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/kexec-tools/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-02-13 07:42:13 +0000
committerJohn Crispin <john@openwrt.org>2015-02-13 07:42:13 +0000
commitcd96421b19a4c9dd058cee724cc5b4fe5f0d74db (patch)
tree13507db4b81aeaf396a52aa6a709627c312dee08 /package/boot/kexec-tools/Makefile
parent15cc0550c78b71c50f1b3a04d2fce68e8425456a (diff)
downloadupstream-cd96421b19a4c9dd058cee724cc5b4fe5f0d74db.tar.gz
upstream-cd96421b19a4c9dd058cee724cc5b4fe5f0d74db.tar.bz2
upstream-cd96421b19a4c9dd058cee724cc5b4fe5f0d74db.zip
kexec-tools: bump version from v2.0.4 to v2.0.9.
- kexec-tools is now distributed with tarballs of .tar.gz and .tar.xz format; .tar.bz2 are not provided anymore. - Add CONFIG_KEXEC_LZMA for selecting lzma support. Patches are updated along to: - Remove the now unnecessary patch 0004-mips_regdefs.patch. - Drop 100-reduce_size.patch because the size reduction is marginal. - Allow zlib and lzma support coexist together. This patch has been merged into upstream project. - Fix kexec-tools' configure.ac. - Fix a few compilation warnings. Size comparison of stripped binaries of kexec malta target with both zlib and lzma support enabled. - Before: 41447 - After: 42583 Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com> SVN-Revision: 44437
Diffstat (limited to 'package/boot/kexec-tools/Makefile')
-rw-r--r--package/boot/kexec-tools/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/package/boot/kexec-tools/Makefile b/package/boot/kexec-tools/Makefile
index e884661c38..e5d4b4b2f4 100644
--- a/package/boot/kexec-tools/Makefile
+++ b/package/boot/kexec-tools/Makefile
@@ -8,23 +8,23 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=kexec-tools
-PKG_VERSION:=2.0.4
+PKG_VERSION:=2.0.9
PKG_RELEASE:=1
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@KERNEL/linux/utils/kernel/kexec
-PKG_MD5SUM:=05992bc8c0673fc55be7b6d27e48a8db
+PKG_MD5SUM:=6681319934e22e74c532bd392ccb1bbb
PKG_FIXUP:=autoreconf
-PKG_CONFIG_DEPENDS := CONFIG_KEXEC_ZLIB
+PKG_CONFIG_DEPENDS := CONFIG_KEXEC_ZLIB CONFIG_KEXEC_LZMA
include $(INCLUDE_DIR)/package.mk
define Package/kexec-tools
SECTION:=utils
CATEGORY:=Utilities
- DEPENDS:=@KERNEL_KEXEC @armeb||@arm||@i386||@powerpc64||@mipsel||@mips +KEXEC_ZLIB:zlib
+ DEPENDS:=@KERNEL_KEXEC @armeb||@arm||@i386||@powerpc64||@mipsel||@mips +KEXEC_ZLIB:zlib +KEXEC_LZMA:liblzma
TITLE:=Kernel boots kernel
URL:=http://kernel.org/pub/linux/kernel/people/horms/kexec-tools/
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
@@ -55,7 +55,7 @@ CONFIGURE_ARGS = \
--libexecdir=/usr/lib \
--sysconfdir=/etc \
$(if $(CONFIG_KEXEC_ZLIB),--with,--without)-zlib \
- --without-lzma
+ $(if $(CONFIG_KEXEC_LZMA),--with,--without)-lzma
TARGET_CFLAGS += -ffunction-sections -fdata-sections
TARGET_LDFLAGS += -Wl,--gc-sections